Quantcast

upgrade to emacs-devel failed

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

upgrade to emacs-devel failed

Vinod Kurup
Hello,

I was happily running emacs-devel 22.0.50 +carbon but decided to
upgrade to fix an annoying bug (#6349 on bugzilla). So, I ran 'sudo
port upgrade emacs-devel' and got an error in the build phase (during
linking, I think).

--->  Building emacs-devel with target bootstrap
...
echo "dispnew.o frame.o scroll.o xdisp.o  window.o charset.o coding.o
category.o ccl.o cm.o term.o xfaces.o   emacs.o keyboard.o macros.o
keymap.o sysdep.o buffer.o filelock.o insdel.o marker.o minibuf.o
fileio.o dired.o filemode.o cmds.o casetab.o casefiddle.o indent.o
search.o regex.o undo.o alloc.o data.o doc.o editfns.o callint.o
eval.o floatfns.o fns.o print.o lread.o abbrev.o syntax.o unexmacosx.o
bytecode.o process.o callproc.o region-cache.o sound.o atimer.o
doprnt.o strftime.o intervals.o textprop.o composite.o md5.o  mac.o
macterm.o macfns.o macmenu.o macselect.o fontset.o fringe.o image.o
terminfo.o lastfile.o    mktime.o " > buildobj.lst
gcc  -prebind -framework Carbon -framework QuickTime -Xlinker
-headerpad -Xlinker E00 -L/opt/local/lib -o temacs pre-crt0.o
dispnew.o frame.o scroll.o xdisp.o  window.o charset.o coding.o
category.o ccl.o cm.o term.o xfaces.o   emacs.o keyboard.o macros.o
keymap.o sysdep.o buffer.o filelock.o insdel.o marker.o minibuf.o
fileio.o dired.o filemode.o cmds.o casetab.o casefiddle.o indent.o
search.o regex.o undo.o alloc.o data.o doc.o editfns.o callint.o
eval.o floatfns.o fns.o print.o lread.o abbrev.o syntax.o unexmacosx.o
bytecode.o process.o callproc.o region-cache.o sound.o atimer.o
doprnt.o strftime.o intervals.o textprop.o composite.o md5.o  mac.o
macterm.o macfns.o macmenu.o macselect.o fontset.o fringe.o image.o
terminfo.o lastfile.o    mktime.o     -lncurses
ld: warning suggest use of -bind_at_load, as lazy binding may result
in errors or different symbols being used
symbol _acosl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _tanl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _tanhl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _asinl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _atan2l used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _atanl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _ceill used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _coshl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _cosl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _expl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _floorl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _fmodl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _frexpl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _hypotl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _ldexpl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _log10l used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _logl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _modfl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _powl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _sinhl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _sinl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
symbol _sqrtl used from dynamic library
/usr/lib/libstdc++.6.dylib(single module) not from earlier dynamic
library /usr/lib/libSystem.B.dylib(ld64.o)
ld: Undefined symbols:
_HICopyAccessibilityActionDescription referenced from QuickTime
expected to be defined in Carbon
_HICopyAccessibilityRoleDescription referenced from QuickTime expected
to be defined in Carbon
_LLCStyleInfoCheckForOpenTypeTables referenced from QuickTime expected
to be defined in ApplicationServices
_LLCStyleInfoGetUserRunFeatures referenced from QuickTime expected to
be defined in ApplicationServices
make[2]: *** [temacs] Error 1
make[1]: *** [bootstrap-build] Error 2
make: *** [bootstrap] Error 2
Warning: the following items did not execute (for emacs-devel):
com.apple.activate com.apple.build com.apple.destroot
com.apple.archive com.apple.install

Here's some info about my system:

$ uname -a
Darwin Vinod-Kurups-Computer.local 7.9.0 Darwin Kernel Version 7.9.0:
Wed Mar 30 20:11:17 PST 2005; root:xnu/xnu-517.12.7.obj~1/RELEASE_PPC
Power Macintosh powerpc

$ port version
Version: 1.200

Is this a bug? Or a misconfiguration on my part.

Thanks,

Vinod

--
Vinod Kurup, MD
[hidden email]
http://kurup.org
_______________________________________________
Darwinports mailing list
[hidden email]
http://www.opendarwin.org/mailman/listinfo/darwinports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: upgrade to emacs-devel failed

Arnaud Delobelle

On 29 Mar 2006, at 17:40, Vinod Kurup wrote:

> Hello,

Hello, I have the current emacs-devel +carbon which installed fine.  
The difference is that I am running Tiger and not Panther.

$ port installed emacs-devel
The following ports are currently installed:
   emacs-devel @22.0.50.1-20051224_2+carbon+darwin_8 (active)

>
> Is this a bug? Or a misconfiguration on my part.
>

I don't know!


--
Arnaud


_______________________________________________
Darwinports mailing list
[hidden email]
http://www.opendarwin.org/mailman/listinfo/darwinports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: upgrade to emacs-devel failed

Vinod Kurup
On 3/29/06, Arnaud Delobelle <[hidden email]> wrote:
> Hello, I have the current emacs-devel +carbon which installed fine.
> The difference is that I am running Tiger and not Panther.
>

Thanks for the feedback. I think I found the problem. Google found me
this message:

http://article.gmane.org/gmane.os.apple.fink.general/20956

which told me to downgrade Quicktime 7.04 to 7.01:

http://www.apple.com/support/downloads/quicktime701reinstallerforquicktime704.html

Problem solved.

Vinod

--
Vinod Kurup, MD
[hidden email]
http://kurup.org
_______________________________________________
Darwinports mailing list
[hidden email]
http://www.opendarwin.org/mailman/listinfo/darwinports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: upgrade to emacs-devel failed

Arnaud Delobelle

On 30 Mar 2006, at 03:29, Vinod Kurup wrote:

>
> Thanks for the feedback. I think I found the problem. Google found me
> this message:
>
> http://article.gmane.org/gmane.os.apple.fink.general/20956
>
> which told me to downgrade Quicktime 7.04 to 7.01:
>
> http://www.apple.com/support/downloads/ 
> quicktime701reinstallerforquicktime704.html
>
> Problem solved.

But I built mine on Quicktime 7.04!

--
Arnaud

_______________________________________________
Darwinports mailing list
[hidden email]
http://www.opendarwin.org/mailman/listinfo/darwinports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: upgrade to emacs-devel failed

Vinod Kurup
On 3/30/06, Arnaud Delobelle <[hidden email]> wrote:
>
> But I built mine on Quicktime 7.04!
>

So...
10.4 + QT 7.04 works
10.3 + QT 7.01 works
10.3 + QT 7.04 doesn't work (n=1)

Anyone with 10.3 and QT 7.04 able to build the latest emacs-devel +carbon?

Vinod

--
Vinod Kurup, MD
[hidden email]
http://kurup.org
_______________________________________________
Darwinports mailing list
[hidden email]
http://www.opendarwin.org/mailman/listinfo/darwinports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: upgrade to emacs-devel failed

Salvatore Domenick Desiano
QT 7.04 doesn't work with DP. It affects a number of ports. This should
probably be a FAQ.

-- Sal
smile.



On Thu, 30 Mar 2006, Vinod Kurup wrote:

o On 3/30/06, Arnaud Delobelle <[hidden email]> wrote:
o >
o > But I built mine on Quicktime 7.04!
o >
o
o So...
o 10.4 + QT 7.04 works
o 10.3 + QT 7.01 works
o 10.3 + QT 7.04 doesn't work (n=1)
o
o Anyone with 10.3 and QT 7.04 able to build the latest emacs-devel +carbon?
o
o Vinod
o
o --
o Vinod Kurup, MD
o [hidden email]
o http://kurup.org
o _______________________________________________
o Darwinports mailing list
o [hidden email]
o http://www.opendarwin.org/mailman/listinfo/darwinports
o
o

--------------
  Salvatore Domenick Desiano
    Research Scientist
      Intelligent Systems Division (QSS Group, Inc.)
        Explorations Technology Directorate
          NASA Ames Research Center

_______________________________________________
Darwinports mailing list
[hidden email]
http://www.opendarwin.org/mailman/listinfo/darwinports
Loading...