Quantcast

livecheck - extracted version is older

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

livecheck - extracted version is older

Jan Stary
This is 2.4.99 on 10.6.8

$ sudo port clean --all opencore-amr
--->  Cleaning opencore-amr
$ port livecheck opencore-amr
Error: livecheck failed for opencore-amr: extracted version '0.1.2' is
older than livecheck.version '0.1.3'

$ find /opt/local/var/macports/ -name \*opencore\*
/opt/local/var/macports//registry/portfiles/opencore-amr-0.1.3_0
/opt/local/var/macports//software/opencore-amr
/opt/local/var/macports//software/opencore-amr/opencore-amr-0.1.3_0.darwin_10.i386.tbz2

What "extracted version 0.1.2"?

        Jan

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: livecheck - extracted version is older

Brandon Allbery
On Thu, Mar 30, 2017 at 6:09 PM, Jan Stary <[hidden email]> wrote:
This is 2.4.99 on 10.6.8

$ sudo port clean --all opencore-amr
--->  Cleaning opencore-amr
$ port livecheck opencore-amr
Error: livecheck failed for opencore-amr: extracted version '0.1.2' is
older than livecheck.version '0.1.3'

"Extracted version" should be the version that livecheck extracted from the web page it checks for the latest version information. So the message is saying that it's being told the latest version is older than the current version. This may mean the page changed format and the livecheck regex needs to be updated, or it's checking the wrong page and needs to be updated to look at a page that has the actual current version.

--
brandon s allbery kf8nh                               sine nomine associates
[hidden email]                                  [hidden email]
unix, openafs, kerberos, infrastructure, xmonad        http://sinenomine.net
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: livecheck - extracted version is older

Jan Stary
On Mar 30 18:12:07, [hidden email] wrote:

> On Thu, Mar 30, 2017 at 6:09 PM, Jan Stary <[hidden email]> wrote:
>
> > This is 2.4.99 on 10.6.8
> >
> > $ sudo port clean --all opencore-amr
> > --->  Cleaning opencore-amr
> > $ port livecheck opencore-amr
> > Error: livecheck failed for opencore-amr: extracted version '0.1.2' is
> > older than livecheck.version '0.1.3'
> >
>
> "Extracted version" should be the version that livecheck extracted from the
> web page it checks for the latest version information. So the message is
> saying that it's being told the latest version is older than the current
> version. This may mean the page changed format and the livecheck regex
> needs to be updated, or it's checking the wrong page and needs to be
> updated to look at a page that has the actual current version.

Thanks. I need to get into port -d :-)

The new opencore is not mentioned in the /rss feed
(and the new libsndfile is not mentioned in the Changelog).
There are even newer versions I need to come up with.

However, "extracted version" sounds a bit confusing here,
given that "extract" is one of the port phases
- nothing's being "extracted" here, in that sense.

Could we make it "detected version" or something
not coliding with "extract"?

        Jan

Loading...