libcxx-5.0.1 using i386 on a PowerMac?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

libcxx-5.0.1 using i386 on a PowerMac?

Jeffrey Walton
Hi Everyone,

I'm trying to update my PowerMac. This is what I see for libcxx during
a 'port upgrade outdated':

--->  Computing dependencies for libcxx
--->  Fetching archive for libcxx
--->  Attempting to fetch
libcxx-5.0.1_4+universal.darwin_9.i386-ppc.tbz2 from
http://packages.macports.org/libcxx
--->  Attempting to fetch
libcxx-5.0.1_4+universal.darwin_9.i386-ppc.tbz2 from
http://aus.us.packages.macports.org/macports/packages/libcxx
--->  Attempting to fetch
libcxx-5.0.1_4+universal.darwin_9.i386-ppc.tbz2 from
http://mse.uk.packages.macports.org/sites/packages.macports.org/libcxx
--->  Building libcxx
Error: Failed to build libcxx: command execution failed

The i386 looks a little unusual. I would expect to see a PowerPC arch,
like ppc970.

Is this expected?

Jeff
Reply | Threaded
Open this post in threaded view
|

Re: libcxx-5.0.1 using i386 on a PowerMac?

ryandesign2
Administrator


On May 29, 2020, at 17:02, Jeffrey Walton  wrote:

> I'm trying to update my PowerMac. This is what I see for libcxx during
> a 'port upgrade outdated':
>
> --->  Computing dependencies for libcxx
> --->  Fetching archive for libcxx
> --->  Attempting to fetch
> libcxx-5.0.1_4+universal.darwin_9.i386-ppc.tbz2 from
> http://packages.macports.org/libcxx
> --->  Attempting to fetch
> libcxx-5.0.1_4+universal.darwin_9.i386-ppc.tbz2 from
> http://aus.us.packages.macports.org/macports/packages/libcxx
> --->  Attempting to fetch
> libcxx-5.0.1_4+universal.darwin_9.i386-ppc.tbz2 from
> http://mse.uk.packages.macports.org/sites/packages.macports.org/libcxx
> --->  Building libcxx
> Error: Failed to build libcxx: command execution failed
>
> The i386 looks a little unusual. I would expect to see a PowerPC arch,
> like ppc970.
>
> Is this expected?

Yes. On Leopard and Tiger, the default universal_archs are i386 and ppc. libcxx installs itself universal by default on Snow Leopard and earlier.

It is also expected that you cannot build libcxx on PowerPC at this time. It just doesn't work there yet. If a port you're trying to install or update is pulling in libcxx, then you can't use that port on PowerPC right now, sorry. This will probably apply to a lot of ports.

Reply | Threaded
Open this post in threaded view
|

Re: libcxx-5.0.1 using i386 on a PowerMac?

Ken Cunningham
In reply to this post by Jeffrey Walton
Hi Everyone,

I'm trying to update my PowerMac. This is what I see for libcxx during
a 'port upgrade outdated':

--->  Computing dependencies for libcxx
--->  Fetching archive for libcxx
--->  Attempting to fetch
libcxx-5.0.1_4+universal.darwin_9.i386-ppc.tbz2 from
http://packages.macports.org/libcxx
--->  Attempting to fetch
libcxx-5.0.1_4+universal.darwin_9.i386-ppc.tbz2 from
http://aus.us.packages.macports.org/macports/packages/libcxx
--->  Attempting to fetch
libcxx-5.0.1_4+universal.darwin_9.i386-ppc.tbz2 from
http://mse.uk.packages.macports.org/sites/packages.macports.org/libcxx
--->  Building libcxx
Error: Failed to build libcxx: command execution failed

The i386 looks a little unusual. I would expect to see a PowerPC arch,
like ppc970.

Is this expected?

Jeff

Not that it can't be done:

$ port -v installed libcxx
  libcxx @5.0.1_4+emulated_tls-universal (active) platform='darwin 9' archs='ppc' date='2019-01-15T21:53:44-0800'

It's just not something that is ready for Macports prime-time yet...

perhaps someday, if @iains finished fleshing out the ABI on clang-7.0 for PPC Darwin, I'll enable it on MacPorts...

Ken