ios-wk2 ews queue slow due to fast/hidpi/image-srcset-relative-svg-canvas-2x.html test

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

ios-wk2 ews queue slow due to fast/hidpi/image-srcset-relative-svg-canvas-2x.html test

Aakash Jain
Hi Everyone,

Many of you might have noticed that ios-wk2 EWS queue has been slow for a while now. This is primarily due to the layout test fast/hidpi/image-srcset-relative-svg-canvas-2x.html being extremely flaky on EWS. Sometimes this also results in false positive, causing EWS to think that the patch being tested broke this test (please ignore that false positive for now).

We tried to skip this test, but that caused subsequent test to fail. This is because some previous test is changing the state in a manner which causes this (or similar) test to fail. We are looking into identifying the bad test and fix the root-cause, but it seems like it might take a while to get that fixed. I'll let you know once it's fixed.

Tracked in https://bugs.webkit.org/show_bug.cgi?id=206993 and https://bugs.webkit.org/show_bug.cgi?id=207038

Thanks
Aakash
_______________________________________________
webkit-dev mailing list
[hidden email]
https://lists.webkit.org/mailman/listinfo/webkit-dev
Reply | Threaded
Open this post in threaded view
|

Re: ios-wk2 ews queue slow due to fast/hidpi/image-srcset-relative-svg-canvas-2x.html test

Aakash Jain
https://bugs.webkit.org/show_bug.cgi?id=207038 has been fixed, thanks to Said Abou-Hallawa.

ios-wk2 ews queue is fast again (https://ews-build.webkit.org/#/builders/24). Please let me know if you notice any issue.

Thanks
Aakash

> On Mar 26, 2020, at 7:01 PM, Aakash Jain <[hidden email]> wrote:
>
> Hi Everyone,
>
> Many of you might have noticed that ios-wk2 EWS queue has been slow for a while now. This is primarily due to the layout test fast/hidpi/image-srcset-relative-svg-canvas-2x.html being extremely flaky on EWS. Sometimes this also results in false positive, causing EWS to think that the patch being tested broke this test (please ignore that false positive for now).
>
> We tried to skip this test, but that caused subsequent test to fail. This is because some previous test is changing the state in a manner which causes this (or similar) test to fail. We are looking into identifying the bad test and fix the root-cause, but it seems like it might take a while to get that fixed. I'll let you know once it's fixed.
>
> Tracked in https://bugs.webkit.org/show_bug.cgi?id=206993 and https://bugs.webkit.org/show_bug.cgi?id=207038
>
> Thanks
> Aakash

_______________________________________________
webkit-dev mailing list
[hidden email]
https://lists.webkit.org/mailman/listinfo/webkit-dev