faust-devel

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

faust-devel

rmgls-2
Hello list,

here is what i get:

fetching  distfiles for faust-devel

and nothing else!

the version is apparently  really old.

faust  version is 2.14.4  on their site
(there is a binary package too).
can we upgrade?

Bests

Raoul
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: faust-devel

ryandesign2
Administrator


On Jun 28, 2020, at 12:24, rmgls wrote:

> here is what i get:
>
> fetching  distfiles for faust-devel
>
> and nothing else!

How long did you wait? Unlike most ports, this one fetches from a git repository. There will be no progress bar or any other output while the download happens. In the current version, it fetches 625MB of data. That may take some time if your network is slow. My network is fairly fast so it only took a minute.


> the version is apparently  really old.
>
> faust  version is 2.14.4  on their site
> (there is a binary package too).
> can we upgrade?

Probably. I haven't touched these ports in awhile. There is another maintainer but he hasn't been active lately either. Would you file a ticket in our issue tracker requesting this update? Or if you're feeling adventurous you can try to do the update yourself and submit a pull request to us.

Reply | Threaded
Open this post in threaded view
|

Re: faust-devel

rmgls-2


> On 29 Jun 2020, at 16:06, Ryan Schmidt <[hidden email]> wrote:
>
>
>
> On Jun 28, 2020, at 12:24, rmgls wrote:
>
>> here is what i get:
>>
>> fetching  distfiles for faust-devel
>>
>> and nothing else!
>
> How long did you wait? Unlike most ports, this one fetches from a git repository. There will be no progress bar or any other output while the download happens. In the current version, it fetches 625MB of data. That may take some time if your network is slow. My network is fairly fast so it only took a minute.
> a long time!
the download did not  start at all.

> the version is apparently  really old.
>>
>> faust  version is 2.14.4  on their site
>> (there is a binary package too).
>> can we upgrade?
>
> Probably. I haven't touched these ports in awhile. There is another maintainer but he hasn't been active lately either. Would you file a ticket in our issue tracker requesting this update? Or if you're feeling adventurous you can try to do the update yourself and submit a pull request to us.
>
i will try to see,  if i am too  stuck, i will  put a ticket.
Thanks Rayan.

Raoul
[hidden email]