`Tk' aqua variant not working as expected in 10.14

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

`Tk' aqua variant not working as expected in 10.14

joerg van den hoff-3
after migration to 10.14 I see strange behaviour after

port install TK +aqua

specifically, display of jpeg images (image creat photo" etc.) does not
work. only an empty canvas is displayed. the same Tcl/Tk script worked
just fine under OSX 10.13.

furthermore, running the same script in 10.14 after

port install Tk

(which installs the default X11 variant) works as expected, too. so, the
X11 display works, the aqua display does not...

before issuing a bug report to the Tcl/Tk project: can anybody confirm
the described behaviour?

thank you

joerg
Reply | Threaded
Open this post in threaded view
|

Re: `Tk' aqua variant not working as expected in 10.14

Marcus Calhoun-Lopez-2
This is an issue that is being worked on upstream.
It should be fixed in the next Tcl/Tk release.
See https://trac.macports.org/ticket/57357 for the MacPorts bug report.

Apparently, there are other Mac issues holding things up.
See the thread: http://code.activestate.com/lists/tcl-core/20396/

-Marcus

> On Nov 8, 2018, at 1:49 PM, joerg van den hoff <[hidden email]> wrote:
>
> after migration to 10.14 I see strange behaviour after
>
> port install TK +aqua
>
> specifically, display of jpeg images (image creat photo" etc.) does not work. only an empty canvas is displayed. the same Tcl/Tk script worked just fine under OSX 10.13.
>
> furthermore, running the same script in 10.14 after
>
> port install Tk
>
> (which installs the default X11 variant) works as expected, too. so, the X11 display works, the aqua display does not...
>
> before issuing a bug report to the Tcl/Tk project: can anybody confirm the described behaviour?
>
> thank you
>
> joerg

Reply | Threaded
Open this post in threaded view
|

Re: `Tk' aqua variant not working as expected in 10.14

joerg van den hoff-3
thanks a lot for this info. this is really appreciated. looking forward
to 8.6.9. :)

best,
joerg

On 08.11.18 22:13, Marcus Calhoun-Lopez wrote:

> This is an issue that is being worked on upstream.
> It should be fixed in the next Tcl/Tk release.
> See https://trac.macports.org/ticket/57357 for the MacPorts bug report.
>
> Apparently, there are other Mac issues holding things up.
> See the thread: http://code.activestate.com/lists/tcl-core/20396/
>
> -Marcus
>
>> On Nov 8, 2018, at 1:49 PM, joerg van den hoff <[hidden email]> wrote:
>>
>> after migration to 10.14 I see strange behaviour after
>>
>> port install TK +aqua
>>
>> specifically, display of jpeg images (image creat photo" etc.) does not work. only an empty canvas is displayed. the same Tcl/Tk script worked just fine under OSX 10.13.
>>
>> furthermore, running the same script in 10.14 after
>>
>> port install Tk
>>
>> (which installs the default X11 variant) works as expected, too. so, the X11 display works, the aqua display does not...
>>
>> before issuing a bug report to the Tcl/Tk project: can anybody confirm the described behaviour?
>>
>> thank you
>>
>> joerg
>
> Delivered-To: [hidden email]
> Received: by 2002:a17:90a:8595:0:0:0:0 with SMTP id m21-v6csp676230pjn;
>          Thu, 8 Nov 2018 13:14:00 -0800 (PST)
> X-Received: by 2002:a17:902:3103:: with SMTP id w3-v6mr6230703plb.51.1541711640460;
>          Thu, 08 Nov 2018 13:14:00 -0800 (PST)
> ARC-Seal: i= a=rsa-sha256; t41711640; cv=none;
>          d=ogle.com; s=arc-20160816;
>          b=zukXFeW2orizDbf52U709GuKbwuOmFocBurJU1B2l6uRhzVT56VKRB4MCtvik/hr
>           D7SrlkTfS9Fuq7sTZ8VBgkGEtvvap/CO2/Thd2py21648xkrjztKk6s2CuCGU45i9NMX
>           SEIGr3/qCdtQHB+2kWwMnB+pFEZhkp/cqrAg18FDHf1D8MEqWZ628fHenboraopsVvT1
>           9t3kODHTx4zwpL12H6s4/K8NO9EHW1BaOmDHPeb6B2JzEBohmGWQ1U125xowQErlNO76
>           EJxyYQz9cFnr7dzqcLkSsiV7pZHsqTz9/AI4qY92/NvEyg778B/ODxRMmiIw2vYhwMat
>           198A=ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=arc-20160816;
>          h=:references:message-id:content-transfer-encoding:cc:date
>           :in-reply-to:from:subject:mime-version:sender:dkim-signature;
>          bh=b8qgB2nGsesfxd8OKNxuGW5DiNc39W7DiXzMUCIvo=;
>          b=AGVRcgAVzgMyqy8BS3dGnuC73GXUqJ5yXIxdvrAEUl8cHxO1geqEhNYse7/sxG/hfP
>           ABAZcvLDWuRSZCcor2ElZbeMFGhIKo/J8Q3fKrgoWjhS01lWePTyWbaOSv4akLNxIyyh
>           l4Ri3DzFPKGGOX9WEAhTtZgNq3tP2kmlHmHr1NkGzhU7HCVeQKLOb/DrGGmT7q4MXYYo
>           gV5LfEWjSaUhIT+IEYhCKhe0jsyfN89Q4VJyFzb1ldbm36QfhDgajGdP1pQ/nq+Q7Fuf
>           ioluZwa4xz6sags0PchMqdFM+aqilBoxxVeRixtnDvs7d9qjtkim+m7CTxz7u5omD2O7
>           Y3yw=ARC-Authentication-Results: i=1; mx.google.com;
>         dkim=ss header.i=@gmail.com header.s 161025 header.b=fyl30wCb;
>         spf=ss (google.com: domain of [hidden email] designates 209.85.220.41 as permitted sender) smtp.mailfrom=[hidden email]
> Return-Path: <[hidden email]>
> Received: from mail-sor-f41.google.com (mail-sor-f41.google.com. [209.85.220.41])
>          by mx.google.com with SMTPS id v9-v6sor5824130pgr.13.2018.11.08.13.13.59
>          for <[hidden email]>
>          (Google Transport Security);
>          Thu, 08 Nov 2018 13:14:00 -0800 (PST)
> Received-SPF: pass (google.com: domain of [hidden email] designates 209.85.220.41 as permitted sender) client-ip 9.85.220.41;
> Authentication-Results: mx.google.com;
>         dkim=ss header.i=@gmail.com header.s 161025 header.b=fyl30wCb;
>         spf=ss (google.com: domain of [hidden email] designates 209.85.220.41 as permitted sender) smtp.mailfrom=[hidden email]
> DKIM-Signature: v= a=rsa-sha256; c=relaxed/relaxed;
>          d=ail.com; s 161025;
>          h=nder:mime-version:subject:from:in-reply-to:date:cc
>           :content-transfer-encoding:message-id:references:to;
>          bh=b8qgB2nGsesfxd8OKNxuGW5DiNc39W7DiXzMUCIvo=;
>          b=fyl30wCbGb7sycwTlXlcWl4bKI7z1ZTyjwAsKxLLkOmZWv+19BLBhKbW2/uIrO60jO
>           Vnau0/UiUYvHMyUClSJHNadqNRPNLxLRg90SisE+kCyfyiDvXjq4awkQHTrjpG3aYg9g
>           b7wF+5XBA9pGH4uE3rPP2KLSfNuXoY/zywcamdnBMIKFowWtiBcr4evM91E5Ao30bie0
>           tUXUZwnWbecpjQ2EHP/j3DZIv3NoVxJ0t+nlC5ObmDx7p+7vF2nCfZp1YIj5t1u/zZOZ
>           pLlB3V7m1o//vyIB1QqhNv48UrfnQAUU0kYB8tfy+5mWposwC3XgvBlV8umVWP+qULHA
>           3rBw=X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
>          d100.net; s 161025;
>          h=gm-message-state:sender:mime-version:subject:from:in-reply-to
>           :date:cc:content-transfer-encoding:message-id:references:to;
>          bh=b8qgB2nGsesfxd8OKNxuGW5DiNc39W7DiXzMUCIvo=;
>          b=Tz5AF8sGzZ3GP9M58MTT8mvS4PFubBtWnHJyPGwGYnRS8daLi4WB2Qtx5Cepkvyiyl
>           u5Fj4OscNCs3vQEDSALdgP8hMrzn+G9hA4gH9sKJseZqwVUYrQNoEcMrVjuQjNEesum8
>           Kmv9+FKMkq4FFcpKyilEvxF6EDDWuSOhDb7WBuqY2yttv+HqAHLP0hZ8Yep2iNHQRUzO
>           iszVIk4gPaplZTGYMTW/UQpsMPRgtlZrIgbxrHxAJbsrlt47cYDKgJ/Ff3ysXSBYKWdd
>           4dxLo9lKKCW7vlEJid/B6O9660ErOifZ4xCYXIwZ7GmHfKmsME8Z1wGbepQlrIGEV21X
>           ARVA=X-Gm-Message-State: AGRZ1gLbGJUynV4jWFEPYE6pQms8ibj3eMTBVzycFzj0Myr/zg9x72WJ
> HAth475Di+HzT+cyR2KYoUpy0WGh
> X-Google-Smtp-Source: AJdET5d8oCww/uD1qSuG59ZIp734zvOo/uEt8+U7r6Ra2CwOr6cGXcNxq/jeq9kP+LPLbBGT1LXWeg=X-Received: by 2002:a65:620f:: with SMTP id d15-v6mr5301282pgv.120.1541711639255;
>          Thu, 08 Nov 2018 13:13:59 -0800 (PST)
> Return-Path: <[hidden email]>
> Received: from [10.10.6.102] ([216.183.64.229])
>          by smtp.gmail.com with ESMTPSA id c7-v6sm5656738pfh.25.2018.11.08.13.13.57
>          (version=S1_2 cipherìDHE-RSA-AES128-GCM-SHA256 bits8/128);
>          Thu, 08 Nov 2018 13:13:58 -0800 (PST)
> Sender: Marcus Calhoun-Lopez <[hidden email]>
> Content-Type: text/plain;
> charset=-ascii
> Mime-Version: 1.0 (Mac OS X Mail 12.1 \(3445.101.1\))
> Subject: Re: `Tk' aqua variant not working as expected in 10.14
> From: Marcus Calhoun-Lopez <[hidden email]>
> In-Reply-To: <[hidden email]>
> Date: Thu, 8 Nov 2018 14:13:56 -0700
> Cc: MacPorts Users <[hidden email]>
> Content-Transfer-Encoding: quoted-printable
> Message-Id: <[hidden email]>
> References: <[hidden email]>
> To: joerg van den hoff <[hidden email]>
> X-Mailer: Apple Mail (2.3445.101.1)
>
> This is an issue that is being worked on upstream.
> It should be fixed in the next Tcl/Tk release.
> See https://trac.macports.org/ticket/57357 for the MacPorts bug report.
>
> Apparently, there are other Mac issues holding things up.
> See the thread: http://code.activestate.com/lists/tcl-core/20396/
>
> -Marcus
>
>> On Nov 8, 2018, at 1:49 PM, joerg van den hoff <[hidden email]> wrote:
>>
>> after migration to 10.14 I see strange behaviour after
>>
>> port install TK +aqua
>>
>> specifically, display of jpeg images (image creat photo" etc.) does not work. only an empty canvas is displayed. the same Tcl/Tk script worked just fine under OSX 10.13.
>>
>> furthermore, running the same script in 10.14 after
>>
>> port install Tk
>>
>> (which installs the default X11 variant) works as expected, too. so, the X11 display works, the aqua display does not...
>>
>> before issuing a bug report to the Tcl/Tk project: can anybody confirm the described behaviour?
>>
>> thank you
>>
>> joerg
>