Ticket #56139 update to pymol 2.1.0 with PyQt interface support

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Ticket #56139 update to pymol 2.1.0 with PyQt interface support

Jack Howarth
Can someone commit my final update to pymol 2.1.0 with PyQt interface support? The packaging switches pymol to use the new PyQt based interface while retaining the tcl/k/pmw dependencies for the legacy plugins. Regarding the legacy plugins, the apbstools one only properly functions on the default python27 variant. This is an issue that exists in the current and prior pymol releases as well and is caused by a combination of pdb2pqr python3 incompatibilities and pmw incompatibilities with python 3.5 and later. Upstream pdb2pqr still hasn't pushed their python3 fixes into apbs-pdb2pqr yet and pmw development seems to be completely stagnant.
                Jack