Quantcast

Re: [macports-ports] 01/02: pkcs11-helper: update to 1.22, depend on pkg-config to fix trace-mode build

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [macports-ports] 01/02: pkcs11-helper: update to 1.22, depend on pkg-config to fix trace-mode build

Ryan Schmidt-24

> On Feb 18, 2017, at 14:49, Dan Villiom Podlaski Christiansen <[hidden email]> wrote:
>
> Dan Villiom Podlaski Christiansen (danchr) pushed a commit to branch master
> in repository macports-ports.
>
>
> https://github.com/macports/macports-ports/commit/7e1fe0ddffb75d7262e3e3edeed03ab18d284049
>
> commit 7e1fe0ddffb75d7262e3e3edeed03ab18d284049
>
> Author: Dan Villiom Podlaski Christiansen <[hidden email]>
> AuthorDate: Tue Mar 28 16:02:25 2017 +0200
>
>
>     pkcs11-helper: update to 1.22, depend on pkg-config to fix trace-mode build
>
> ---
>  security/pkcs11-helper/Portfile | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
>
>
> diff --git a/security/pkcs11-helper/Portfile b/security/pkcs11-helper/Portfile
>
> index dfad741..cecbd08 100644
>
> --- a/security/pkcs11-helper/Portfile
>
> +++ b/security/pkcs11-helper/Portfile
>
> @@ -3,7 +3,7 @@
>
>  PortSystem          1.0
>  PortGroup           github 1.0
>  
>
> -github.setup        OpenSC pkcs11-helper 1.11 pkcs11-helper-
>
> +github.setup        OpenSC pkcs11-helper 1.22 pkcs11-helper-
>
>  categories          security
>  platforms           darwin freebsd
>  license             GPL-2+ BSD
>
> @@ -12,10 +12,11 @@ maintainers         nomaintainer
>
>  description         Library that simplifies the interaction with PKCS#11 providers for end-user applications using a simple API and optional OpenSSL engine
>  long_description    ${description}
>  
>
> -checksums           rmd160  5caa2bc24a9d4d2bb12a8f45178d453de28f50a8 \
>
> -                    sha256  ea182c014024acadbd2463b38abd9adbb2445fd4289f3dca3dbfed39a08b3f5b
>
> +checksums           rmd160  eea8faeb337ee3793cfd75485438ff963410ce25 \
>
> +                    sha256  13cae76c36a00362db7328d733ce114f52e93c21f25bdba8a12af4437c4c149e
>
>  
>  depends_lib         port:gnutls \
>
> +                    port:pkgconfig \
>
>                      path:lib/libssl.dylib:openssl
>  

Unless pkcs11-helper is unusual and actually uses pkgconfig at runtime, pkgconfig should only be a build dependency, not a library dependency.



Loading...