Re: [MacPorts] #51801: qt5: support older versions of OS X via different versions of Qt 5

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #51801: qt5: support older versions of OS X via different versions of Qt 5

MacPorts
#51801: qt5: support older versions of OS X via different versions of Qt 5
--------------------------+---------------------------------
  Reporter:  dliessi      |      Owner:  MarcusCalhoun-Lopez
      Type:  enhancement  |     Status:  closed
  Priority:  Normal       |  Milestone:
 Component:  ports        |    Version:
Resolution:  wontfix      |   Keywords:
      Port:  qt5          |
--------------------------+---------------------------------
Changes (by MarcusCalhoun-Lopez):

 * status:  new => closed
 * resolution:   => wontfix


Comment:

 Although some version of Qt can build on 10.7-10.12 (see changesets in
 this ticket and #52922), I can see no realistic way of adding support for
 10.6.[[BR]]
 Going back many versions, Qt 5 uses
 [https://developer.apple.com/reference/corefoundation/1542555-cfrunlooptimercreatewithhandler?language=objc
 CFRunLoopTimerCreateWithHandler], which was not introduced until Mac OS X
 10.7.[[BR]]
 Sorry I can not do more.

--
Ticket URL: <https://trac.macports.org/ticket/51801#comment:14>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #51801: qt5: support older versions of OS X via different versions of Qt 5

MacPorts
#51801: qt5: support older versions of OS X via different versions of Qt 5
--------------------------+---------------------------------
  Reporter:  dliessi      |      Owner:  MarcusCalhoun-Lopez
      Type:  enhancement  |     Status:  closed
  Priority:  Normal       |  Milestone:
 Component:  ports        |    Version:
Resolution:  wontfix      |   Keywords:
      Port:  qt5          |
--------------------------+---------------------------------

Comment (by dliessi):

 Didn't 5.3.x compile on 10.6?
 See the Portfile before commit [https://github.com/macports/macports-
 ports/commit/2e445fc50b1507164f6a10c6633170e68bf1c07e
 2e445fc50b1507164f6a10c6633170e68bf1c07e].

--
Ticket URL: <https://trac.macports.org/ticket/51801#comment:15>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #51801: qt5: support older versions of OS X via different versions of Qt 5

MacPorts
In reply to this post by MacPorts
#51801: qt5: support older versions of OS X via different versions of Qt 5
--------------------------+---------------------------------
  Reporter:  dliessi      |      Owner:  MarcusCalhoun-Lopez
      Type:  enhancement  |     Status:  closed
  Priority:  Normal       |  Milestone:
 Component:  ports        |    Version:
Resolution:  wontfix      |   Keywords:
      Port:  qt5          |
--------------------------+---------------------------------

Comment (by MarcusCalhoun-Lopez):

 Replying to [comment:15 dliessi]:
 > Didn't 5.3.x compile on 10.6?
 > See the Portfile before commit [https://github.com/macports/macports-
 ports/commit/2e445fc50b1507164f6a10c6633170e68bf1c07e
 2e445fc50b1507164f6a10c6633170e68bf1c07e].
 I did not try to get a version of Qt 5.3 working because, according to the
 [https://github.com/wbsoft/frescobaldi/blob/master/INSTALL#L40 INSTALL]
 file, Frescobaldi 3.x.x requires !''Qt >= 5.4.!''[[BR]]
 If you have some indication to the contrary, please let me know.

--
Ticket URL: <https://trac.macports.org/ticket/51801#comment:16>
MacPorts <https://www.macports.org/>
Ports system for macOS