Re: #13182: Apache2 failure to start due to mod_ssl loading problem under Mac OS X 10.5 Leopard

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: #13182: Apache2 failure to start due to mod_ssl loading problem under Mac OS X 10.5 Leopard

Calendar and Contacts Server
#13182: Apache2 failure to start due to mod_ssl loading problem under Mac OS X 10.5
Leopard
-------------------------------+--------------------------------------------
  Reporter:  [hidden email]  |       Owner:  [hidden email]          
      Type:  defect            |      Status:  new                          
  Priority:  Normal            |   Milestone:  Port Bugs                    
 Component:  ports             |     Version:  1.5.0                        
Resolution:                    |    Keywords:  apache2, ssl, mod_ssl, Leopard
-------------------------------+--------------------------------------------
Comment (by [hidden email]):

 Dunno if this is helpful, but one of the folks who responsed on Nabble got
 it working:


 ----

 It works when I remove -export-symbols-regex ssl_module from the libtool
 --silent --mode=link step of building mod_ssl.so

 I did it by finding the commandline that created mod_ssl.la and rerunning
 that line in the modules/ssl directory but without -export-symbols-regex
 ssl_module

 I spent enough time figuring out what the problem was that I can't afford
 to spend any more on making the solution clean.  Anyone know how to patch
 the source so that it puts in a better regex that includes the ssl_cmd
 symbols as well?

--
Ticket URL: <http://trac.macosforge.org/projects/macports/ticket/13182#comment:6>
MacPorts </projects/macports>
Ports system for Mac OS
_______________________________________________
macports-tickets mailing list
[hidden email]
http://lists.macosforge.org/mailman/listinfo/macports-tickets