Quantcast

Permission denied writing temp file during restore_ports.tcl on macOS sierra

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Permission denied writing temp file during restore_ports.tcl on macOS sierra

Kendall Shaw-2

Building gmp fails because it can’t write to a directory that it creates in /var/folders/xx/_blah/T:

 

:info:build make: error: couldn't create cache file '/var/folders/sr/_cb62lmn0v36cvbz11hjgy7r0000gn/T/xcrun_db-eQZtJHV5' (errno=Permission denied)

 

Changing permissions using chmod -R g+w  /var/folders/sr/_cb62lmn0v36cvbz11hjgy7r0000gn doesn’t change, it still creates a directory and then says it can’t write to it. And I’ve tried a few variations of this changing group and ownership

 

Do you know what needs to be done?

 

Kendall

 

 

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Permission denied writing temp file during restore_ports.tcl on macOS sierra

Kendall Shaw-2

I didn’t figure out the problem. But, after uninstalling macports completely and reinstalling, at least gmp has installed and I am reinstalling the high level ports with lots of dependencies now instead of using restore_ports.tcl

 

From: macports-users <[hidden email]> on behalf of Kendall Shaw <[hidden email]>
Date: Thursday, April 20, 2017 at 9:30 AM
To: macports-users <[hidden email]>
Subject: Permission denied writing temp file during restore_ports.tcl on macOS sierra

 

Building gmp fails because it can’t write to a directory that it creates in /var/folders/xx/_blah/T:

 

:info:build make: error: couldn't create cache file '/var/folders/sr/_cb62lmn0v36cvbz11hjgy7r0000gn/T/xcrun_db-eQZtJHV5' (errno=Permission denied)

 

Changing permissions using chmod -R g+w  /var/folders/sr/_cb62lmn0v36cvbz11hjgy7r0000gn doesn’t change, it still creates a directory and then says it can’t write to it. And I’ve tried a few variations of this changing group and ownership

 

Do you know what needs to be done?

 

Kendall

 

 

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Permission denied writing temp file during restore_ports.tcl on macOS sierra

Ryan Schmidt-24
In reply to this post by Kendall Shaw-2

> On Apr 20, 2017, at 11:30, Kendall Shaw <[hidden email]> wrote:
>
> Building gmp fails because it can’t write to a directory that it creates in /var/folders/xx/_blah/T:
>  
> :info:build make: error: couldn't create cache file '/var/folders/sr/_cb62lmn0v36cvbz11hjgy7r0000gn/T/xcrun_db-eQZtJHV5' (errno=Permission denied)
>  
> Changing permissions using chmod -R g+w  /var/folders/sr/_cb62lmn0v36cvbz11hjgy7r0000gn doesn’t change, it still creates a directory and then says it can’t write to it. And I’ve tried a few variations of this changing group and ownership
>  
> Do you know what needs to be done?


https://trac.macports.org/ticket/43282



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Permission denied writing temp file during restore_ports.tcl on macOS sierra

Kendall Shaw-2
On 4/20/17, 3:38 PM, "Ryan Schmidt" <[hidden email]> wrote:

   
    > On Apr 20, 2017, at 11:30, Kendall Shaw <[hidden email]> wrote:
    >
    > Building gmp fails because it can’t write to a directory that it creates in /var/folders/xx/_blah/T:
    >  
    > :info:build make: error: couldn't create cache file '/var/folders/sr/_cb62lmn0v36cvbz11hjgy7r0000gn/T/xcrun_db-eQZtJHV5' (errno=Permission denied)
    >  
    > Changing permissions using chmod -R g+w  /var/folders/sr/_cb62lmn0v36cvbz11hjgy7r0000gn doesn’t change, it still creates a directory and then says it can’t write to it. And I’ve tried a few variations of this changing group and ownership
    >  
    > Do you know what needs to be done?
   
   
    https://urldefense.proofpoint.com/v2/url?u=https-3A__trac.macports.org_ticket_43282&d=DwIFaQ&c=DS6PUFBBr_KiLo7Sjt3ljp5jaW5k2i9ijVXllEdOozc&r=JgwnBEpN1c-DDmq-Up2QMq9rrGyfWK0KtSpT7dxRglA&m=fAx5wOxCIxR25IU56EjCH4Re6Sk0Z4PSSm2_wzgJAaw&s=tsSp5TIwFSwPhYolE9qCx8gnwiEXlS-YAOeXz9mUK3M&e= 
   
   
   
Thank you. I had tried deleting the ‘T’ directory but not the parent. I’m not sure why the same problem didn’t happen again after removing and reinstalling macports.

I noticed that it used the same temporary directory name again after deleting the T directory, which seems odd, e.g. it used xcrun_db-eQZtJHV5 again.

Kendall

Loading...