Opengl support in webkit

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Opengl support in webkit

Nagendra K
Hi ,

Does WebKit engine mandate to use any version of opengl?
Can we link any opengl which my platform has.
 
Could see that for opengles2 is there with a flag in if condition and else condition to gl.h.
So if else is used, can I link to any opengl version which my platform has ?

Regards,
Nagendra

_______________________________________________
webkit-dev mailing list
[hidden email]
https://lists.webkit.org/mailman/listinfo/webkit-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Opengl support in webkit

Dean Jackson-7


> On 21 Jul 2017, at 13:47, Nagendra K <[hidden email]> wrote:
>
> Hi ,
>
> Does WebKit engine mandate to use any version of opengl?
> Can we link any opengl which my platform has.

As long as your OpenGL is compatible with OpenGL 4.0 and above, or OpenGL ES 2.0 and above, I think you'll be fine.

Dean

>  
> Could see that for opengles2 is there with a flag in if condition and else condition to gl.h.
> So if else is used, can I link to any opengl version which my platform has ?
>

_______________________________________________
webkit-dev mailing list
[hidden email]
https://lists.webkit.org/mailman/listinfo/webkit-dev
Loading...