NRPE SSL connections fail

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

NRPE SSL connections fail

Randall Perry
I've installed NRPE by compiling myself and also with darwinports. With both
I get the same errors trying to connect:

I get this from nrpe (with debugging on):
   Error: Could not complete SSL handshake. 2\n

And this from check_nrpe:
   CHECK_NRPE: Error - Could not complete SSL handshake.

Also tried running both without ssl. nrpe crashed on the remote machine,
while nagios host gave error:
   CHECK_NRPE: Socket timeout after 10 seconds

I've read the FAQ on this issue and verified that everything is kosher.
   http://www.nagios.org/faqs/viewfaq.php?faq_id=191

Both main and remote host have openssl 0.9.8a installed in /usr/local/ssl.

Anyone else experienced this?


 
--
Randall Perry
sysTame

Xserve Web Hosting/Co-location/Leasing
QuickTime Streaming
Mac Consulting/Sales

http://www.systame.com/



_______________________________________________
Darwinports mailing list
[hidden email]
http://www.opendarwin.org/mailman/listinfo/darwinports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: NRPE SSL connections fail

Mark Duling
Randall Perry <[hidden email]> writes:

>I've installed NRPE by compiling myself and also with darwinports. With
>both
>I get the same errors trying to connect:
>
>I get this from nrpe (with debugging on):
>   Error: Could not complete SSL handshake. 2\n
>
>And this from check_nrpe:
>   CHECK_NRPE: Error - Could not complete SSL handshake.
>
>Also tried running both without ssl. nrpe crashed on the remote machine,
>while nagios host gave error:
>   CHECK_NRPE: Socket timeout after 10 seconds
>
>I've read the FAQ on this issue and verified that everything is kosher.
>   http://www.nagios.org/faqs/viewfaq.php?faq_id=191
>
>Both main and remote host have openssl 0.9.8a installed in /usr/local/ssl.
>
>Anyone else experienced this?

I did the nrpe port after Nagios just to round out the Nagios related
stuff; but I confess I've never used it.  I wouldn't be surprised if no
one else has on the list either.  So you will probably have to turn to the
Nagios support list for help on this.  If you get an answer that solves it
I would love to know about it.  Besides the fact that I might try it
sometime, if it happens to make a good general tip on OS X the nrpe ui_msg
text could include it.

Mark

_______________________________________________
Darwinports mailing list
[hidden email]
http://www.opendarwin.org/mailman/listinfo/darwinports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: NRPE SSL connections fail

Randall Perry
> Randall Perry <[hidden email]> writes:

>> I get this from nrpe (with debugging on):
>>   Error: Could not complete SSL handshake. 2\n

>
> I did the nrpe port after Nagios just to round out the Nagios related
> stuff; but I confess I've never used it.  I wouldn't be surprised if no
> one else has on the list either.  So you will probably have to turn to the
> Nagios support list for help on this.  If you get an answer that solves it
> I would love to know about it.  Besides the fact that I might try it
> sometime, if it happens to make a good general tip on OS X the nrpe ui_msg
> text could include it.
>
> Mark

I'll be sure to post a solution when I find it.

--
Randall Perry
sysTame

Xserve Web Hosting/Co-location/Leasing
QuickTime Streaming
Mac Consulting/Sales

http://www.systame.com/



_______________________________________________
Darwinports mailing list
[hidden email]
http://www.opendarwin.org/mailman/listinfo/darwinports
Loading...