MacPorts upgrade outdated taking forever after Big Sur 11.2.1 update

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

MacPorts upgrade outdated taking forever after Big Sur 11.2.1 update

Tom Gederberg-2
I just upgraded from Big Sur 11.1 to 11.2.1 and then did a

sudo port -v selfupdate
sudo port -v upgrade outdated

It is taking hours and seems to be compiling everything from scratch.  It have Neve taken this log before and I usually update my ports every week.

Is anyone else experiencing this?

Tom Gederberg
Reply | Threaded
Open this post in threaded view
|

Re: MacPorts upgrade outdated taking forever after Big Sur 11.2.1 update

ryandesign2
Administrator


On Feb 11, 2021, at 19:27, Tom Gederberg wrote:

> I just upgraded from Big Sur 11.1 to 11.2.1 and then did a
>
> sudo port -v selfupdate
> sudo port -v upgrade outdated
>
> It is taking hours and seems to be compiling everything from scratch.  It have Neve taken this log before and I usually update my ports every week.
>
> Is anyone else experiencing this?

Do you see lines of output indicating that it is trying to download packages and failing to find them, or do you not see any such lines?

If you do see those lines, what are some of the package names? We may simply not have built them yet.

Reply | Threaded
Open this post in threaded view
|

Re: MacPorts upgrade outdated taking forever after Big Sur 11.2.1 update

Tom Gederberg-2
It finally finished.  The lines scroll by so fast it was hard to see what it was doing, but it is completed successfully.

> On Feb 11, 2021, at 7:57 PM, Ryan Schmidt <[hidden email]> wrote:
>
>
>
> On Feb 11, 2021, at 19:27, Tom Gederberg wrote:
>
>> I just upgraded from Big Sur 11.1 to 11.2.1 and then did a
>>
>> sudo port -v selfupdate
>> sudo port -v upgrade outdated
>>
>> It is taking hours and seems to be compiling everything from scratch.  It have Neve taken this log before and I usually update my ports every week.
>>
>> Is anyone else experiencing this?
>
> Do you see lines of output indicating that it is trying to download packages and failing to find them, or do you not see any such lines?
>
> If you do see those lines, what are some of the package names? We may simply not have built them yet.
>