[MacPorts] #58088: Trying to upgrade libVLC is still not working, despite ticket #58073

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[MacPorts] #58088: Trying to upgrade libVLC is still not working, despite ticket #58073

MacPorts
#58088: Trying to upgrade libVLC is still not working, despite ticket #58073
-------------------------------------------------+-------------------------
 Reporter:  TheLastLovemark                      |      Owner:  (none)
     Type:  defect                               |     Status:  new
 Priority:  Normal                               |  Milestone:
Component:  ports                                |    Version:  2.5.4
 Keywords:  build fail, libVLC, upgrade fail,    |       Port:  libVLC
  x264 error                                     |
-------------------------------------------------+-------------------------
 I tried to upgrade the latest build of libVLC, but x264 is still causing
 trouble.

 please ses the attached log file

--
Ticket URL: <https://trac.macports.org/ticket/58088>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #58088: Trying to upgrade libVLC is still not working, despite ticket #58073

MacPorts
#58088: Trying to upgrade libVLC is still not working, despite ticket #58073
-------------------------+-------------------------------------------------
  Reporter:              |      Owner:  (none)
  TheLastLovemark        |
      Type:  defect      |     Status:  new
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:  2.5.4
Resolution:              |   Keywords:  build fail, libVLC, upgrade fail,
      Port:  libVLC      |  x264 error
-------------------------+-------------------------------------------------
Changes (by TheLastLovemark):

 * Attachment "main.log" added.

 libVLC main.log

--
Ticket URL: <https://trac.macports.org/ticket/58088>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #58088: Trying to upgrade libVLC is still not working, despite ticket #58073

MacPorts
In reply to this post by MacPorts
#58088: Trying to upgrade libVLC is still not working, despite ticket #58073
------------------------------+--------------------
  Reporter:  TheLastLovemark  |      Owner:  (none)
      Type:  defect           |     Status:  new
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:  2.5.4
Resolution:                   |   Keywords:
      Port:  libVLC           |
------------------------------+--------------------
Changes (by kencu):

 * keywords:  build fail, libVLC, upgrade fail, x264 error =>


--
Ticket URL: <https://trac.macports.org/ticket/58088#comment:1>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #58088: Trying to upgrade libVLC is still not working, despite ticket #58073

MacPorts
In reply to this post by MacPorts
#58088: Trying to upgrade libVLC is still not working, despite ticket #58073
------------------------------+--------------------
  Reporter:  TheLastLovemark  |      Owner:  (none)
      Type:  defect           |     Status:  closed
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:  2.5.4
Resolution:  worksforme       |   Keywords:
      Port:  libVLC           |
------------------------------+--------------------
Changes (by kencu):

 * status:  new => closed
 * resolution:   => worksforme


Comment:

 Your log shows the new patch didn't apply for you, and you have the same
 error as before.

 As it builds here and on all the buildbots, including your system
 <https://build.macports.org/builders/ports-10.12_x86_64-builder/builds/84986>
 it appears you just need to wait a bit for the changes to roll out to your
 system in a `sudo port selfupdate`.

 Try again in a few hours. If you want to know for sure that you have the
 updated patch, you can look in your ports directory and see if it is
 there:
 {{{
 cd `port dir libVLC`/files
 ls
 }}}
 and look for the new patchfile.
 {{{
 patch-modules-codec-x264-new-api.diff
 }}}

 If you confirm you have the patchfile, and it still does not build for
 you, please re-open this ticket with a new log and we'll sort you out!

--
Ticket URL: <https://trac.macports.org/ticket/58088#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #58088: Trying to upgrade libVLC is still not working, despite ticket #58073

MacPorts
In reply to this post by MacPorts
#58088: Trying to upgrade libVLC is still not working, despite ticket #58073
------------------------------+--------------------
  Reporter:  TheLastLovemark  |      Owner:  (none)
      Type:  defect           |     Status:  closed
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:  2.5.4
Resolution:  worksforme       |   Keywords:
      Port:  libVLC           |
------------------------------+--------------------

Comment (by RJVB):

 I can confirm that the patch worked: I upgraded port:x264 and rebuilt VLC
 before giving the green light on Ken's PR.
 (I also didn't try to do any x264 compression through VLC though).

--
Ticket URL: <https://trac.macports.org/ticket/58088#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS