[MacPorts] #58087: openCV +avx2 +contrib +debug +eigen +gdal +opencl +openni +python27 +qt5 +tbb +vtk upgrade/install fails to build and causing problems with upgrade of objectmarker

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[MacPorts] #58087: openCV +avx2 +contrib +debug +eigen +gdal +opencl +openni +python27 +qt5 +tbb +vtk upgrade/install fails to build and causing problems with upgrade of objectmarker

MacPorts
#58087: openCV +avx2 +contrib +debug +eigen +gdal +opencl +openni +python27 +qt5
+tbb +vtk upgrade/install fails to build and causing problems with upgrade
of objectmarker
-------------------------------------------------+-------------------------
 Reporter:  TheLastLovemark                      |      Owner:  (none)
     Type:  defect                               |     Status:  new
 Priority:  Normal                               |  Milestone:
Component:  ports                                |    Version:  2.5.4
 Keywords:  opencv, build fail, upgrade fail,    |       Port:  opencv
  install fail, objectmarker, broken files,      |
  broken port, variants, dependencies            |
-------------------------------------------------+-------------------------
 Hi, I'm running MP 2.5.4 on a 2010 MBP with the latest version of Sierra
 (10.12.6/Darwin16.7.0).

 As mentioned in ticket #58072, I recently completed a selfupdate after not
 doing so for a long while. When I tried to run {{{port upgrade outdated}}}
 and/or {{{port rev-upgrade}}}, something failed and I was presented with a
 list of broken ports, e.g.:

 {{{
 --->  Found 42 broken files, matching files to ports
 rb-eventmachine is using libstdc++ (this installation is configured to use
 libc++)
 sqlmap is using libstdc++ (this installation is configured to use libc++)
 openmpi-gcc5 is using libstdc++ (this installation is configured to use
 libc++)
 openmpi-gcc6 is using libstdc++ (this installation is configured to use
 libc++)
 openmpi-gcc49 is using libstdc++ (this installation is configured to use
 libc++)
 --->  Found 11 broken ports, determining rebuild order
 DEBUG: Broken: R-app
 DEBUG: Broken: openmpi-gcc6
 DEBUG: Broken: openmpi-gcc49
 DEBUG: Broken: enblend
 DEBUG: Broken: ntop
 DEBUG: Broken: objectmarker
 DEBUG: Broken: libkdcraw
 DEBUG: Broken: libVLC
 DEBUG: Broken: rb-eventmachine
 DEBUG: Broken: sqlmap
 DEBUG: Broken: openmpi-gcc5
 DEBUG: Processing port R-app @0:1.68_1
 DEBUG: Processing port openmpi-gcc6 @0:3.0.0_0 +fortran
 DEBUG: Processing port openmpi-gcc49 @0:3.0.0_0 +fortran
 DEBUG: Processing port enblend @0:4.1.5_4
 DEBUG: Processing port hugin-app @0:2018.0.0_3 +accelerate+python27
 DEBUG: Processing port luminance-hdr @0:2.5.1_4 +external
 DEBUG: Processing port ntop @0:5.0.1_3
 DEBUG: Processing port objectmarker @0:20070501_2
 DEBUG: Processing port libkdcraw @0:4.14.3_5
 DEBUG: Processing port libVLC @0:2.2.8_7 +quartz
 DEBUG: Processing port rb-eventmachine @0:0.12.10_0
 DEBUG: Processing port rb-twitter-stream @0:0.1.14_0
 DEBUG: Processing port rb-tweetstream @0:1.0.4_0
 DEBUG: Processing port sqlmap @0:0.9_1 +python27
 DEBUG: Processing port openmpi-gcc5 @0:3.0.0_0 +fortran
 You can always run 'port rev-upgrade' again to fix errors.
 The following ports will be rebuilt:
  R-app @1.68
  openmpi-gcc6 @3.0.0+fortran
  openmpi-gcc49 @3.0.0+fortran
  enblend @4.1.5
  ntop @5.0.1
  objectmarker @20070501
  libkdcraw @4.14.3
  libVLC @2.2.8+quartz
  rb-eventmachine @0.12.10
  sqlmap @0.9+python27
  openmpi-gcc5 @3.0.0+fortran
 Continue? [Y/n]:
 }}}

 Initially, the list was much longer and ''I was able to manually upgrade
 some of the ports'' (not shown). The first one I came here for help with
 is the ticket mentioned above (‚Äč#58072). I was redirected to try the
 solution suggested at ‚Äčticket #58066 by ''{{{kencu}}},'' which worked.

 When I tried to manually upgrade the port ''objectmarker,'' **it failed**
 and I noticed that some of the broken files are tied to ''opencv.'' **I
 tried a similar solution with opencv** using the one described in #58066
 by trying {{{port -v -d install openCV +avx2 +contrib +debug +eigen +gdal
 +opencl +openni +python27 +qt5 +tbb +vtk}}}. **This did not work.**

 openCV is critical to the work I do. Help with this is very much
 appreciated.

 The log file for **opencv** is attached.

--
Ticket URL: <https://trac.macports.org/ticket/58087>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #58087: openCV +avx2 +contrib +debug +eigen +gdal +opencl +openni +python27 +qt5 +tbb +vtk upgrade/install fails to build and causing problems with upgrade of objectmarker

MacPorts
#58087: openCV +avx2 +contrib +debug +eigen +gdal +opencl +openni +python27 +qt5
+tbb +vtk upgrade/install fails to build and causing problems with upgrade
of objectmarker
-------------------------+-------------------------------------------------
  Reporter:              |      Owner:  (none)
  TheLastLovemark        |
      Type:  defect      |     Status:  new
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:  2.5.4
Resolution:              |   Keywords:  opencv, build fail, upgrade fail,
                         |  install fail, objectmarker, broken files,
      Port:  opencv      |  broken port, variants, dependencies
-------------------------+-------------------------------------------------
Changes (by TheLastLovemark):

 * Attachment
 "openCV+avx2+contrib+debug+eigen+gdal+opencl+openni+python27+qt5+tbb+vtk_main.log"
 added.

 openCV +variants main.log

--
Ticket URL: <https://trac.macports.org/ticket/58087>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #58087: openCV +avx2 +contrib +debug +eigen +gdal +opencl +openni +python27 +qt5 +tbb +vtk upgrade/install fails to build and causing problems with upgrade of objectmarker

MacPorts
In reply to this post by MacPorts
#58087: openCV +avx2 +contrib +debug +eigen +gdal +opencl +openni +python27 +qt5
+tbb +vtk upgrade/install fails to build and causing problems with upgrade
of objectmarker
------------------------------+----------------------
  Reporter:  TheLastLovemark  |      Owner:  stromnov
      Type:  defect           |     Status:  assigned
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:  2.5.4
Resolution:                   |   Keywords:
      Port:  opencv           |
------------------------------+----------------------
Changes (by ryandesign):

 * keywords:
     opencv, build fail, upgrade fail, install fail, objectmarker, broken
     files, broken port, variants, dependencies
     =>
 * cc: stromnov (removed)
 * status:  new => assigned
 * owner:  (none) => stromnov


Comment:

 Looks like the error in the log is:

 {{{
 :info:build In file included from
 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/work/opencv-3.4.3/modules/dnn/misc/caffe
 /opencv-caffe.pb.cc:4:
 :info:build
 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/work/opencv-3.4.3/modules/dnn/misc/caffe
 /opencv-caffe.pb.h:17:2: error: This file was generated by an older
 version of protoc which is
 :info:build #error This file was generated by an older version of protoc
 which is
 :info:build  ^
 :info:build
 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/work/opencv-3.4.3/modules/dnn/misc/caffe
 /opencv-caffe.pb.h:18:2: error: incompatible with your Protocol Buffer
 headers.  Please
 :info:build #error incompatible with your Protocol Buffer headers.  Please
 :info:build  ^
 :info:build
 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/work/opencv-3.4.3/modules/dnn/misc/caffe
 /opencv-caffe.pb.h:19:2: error: regenerate this file with a newer version
 of protoc.
 :info:build #error regenerate this file with a newer version of protoc.
 :info:build  ^
 :info:build
 }}}

 Or, more legibly:

 "This file was generated by an older version of protoc which is
 incompatible with your Protocol Buffer headers.  Please regenerate this
 file with a newer version of protoc."

 Which is already filed as #56349.

--
Ticket URL: <https://trac.macports.org/ticket/58087#comment:1>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #58087: openCV +avx2 +contrib +debug +eigen +gdal +opencl +openni +python27 +qt5 +tbb +vtk: This file was generated by an older version of protoc which is incompatible with your Protocol Buffer headers (was: openCV +avx2 +contrib +debug +eigen +gdal +opencl +openni +python27 +qt5 +tbb +vtk upgrade/install fails to build and causing problems with upgrade of objectmarker)

MacPorts
In reply to this post by MacPorts
#58087: openCV +avx2 +contrib +debug +eigen +gdal +opencl +openni +python27 +qt5
+tbb +vtk: This file was generated by an older version of protoc which is
incompatible with your Protocol Buffer headers
------------------------------+----------------------
  Reporter:  TheLastLovemark  |      Owner:  stromnov
      Type:  defect           |     Status:  closed
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:  2.5.4
Resolution:  duplicate        |   Keywords:
      Port:  opencv           |
------------------------------+----------------------
Changes (by ryandesign):

 * status:  assigned => closed
 * resolution:   => duplicate


--
Ticket URL: <https://trac.macports.org/ticket/58087#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS