[MacPorts] #57729: opencv: please update to version 4.0

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[MacPorts] #57729: opencv: please update to version 4.0

MacPorts
#57729: opencv: please update to version 4.0
-----------------------+----------------------
 Reporter:  gallafent  |      Owner:  stromnov
     Type:  update     |     Status:  assigned
 Priority:  Normal     |  Milestone:
Component:  ports      |    Version:  2.5.4
 Keywords:             |       Port:  opencv
-----------------------+----------------------
 As per [https://opencv.org/opencv-4-0-0.html], OpenCV version 4.0 was
 release on 2018-11-20, and the 3.4 branch is now in maintenance mode.
 Please update the port to build version 4.0 by default. I imagine there
 may be people that require 3.4 rather than 4.0 for the time being, which
 might lead to the port forking into opencv3 and opencv (or whatever the
 convention here is) … I guess any such people should make themselves known
 in this ticket, if retaining 3.4 is required.

 Depending on speed of progress of this ticket, I may end up having a go at
 adapting the existing portfile myself. If I do, I'll report progress here.

 Thanks!

--
Ticket URL: <https://trac.macports.org/ticket/57729>
MacPorts <https://www.macports.org/>
Ports system for macOS