[MacPorts] #57255: Soprano needs Java

classic Classic list List threaded Threaded
20 messages Options
Reply | Threaded
Open this post in threaded view
|

[MacPorts] #57255: Soprano needs Java

MacPorts
#57255: Soprano needs Java
--------------------------------+---------------------
 Reporter:  milomak             |      Owner:  (none)
     Type:  defect              |     Status:  new
 Priority:  Normal              |  Milestone:
Component:  ports               |    Version:  2.5.4
 Keywords:  java xcode soprano  |       Port:  soprano
--------------------------------+---------------------
 when i try to install soprano, the following error presents itself:
 $ sudo port install soprano
 --->  Computing dependencies for soprano
 --->  Configuring soprano
 Error: soprano requires the Java for Mac OS X development headers.
 Error: Make sure your Xcode installation is complete.
 Error: Failed to configure soprano: missing Java headers
 Error: See
 /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_soprano/soprano/main.log
 for details.
 Error: Follow https://guide.macports.org/#project.tickets to report a bug.
 Error: Processing of port soprano failed

 Java is installed:
 java --version
 java 11 2018-09-25
 Java(TM) SE Runtime Environment 18.9 (build 11+28)
 Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11+28, mixed mode)

 i've used installed the latest oracle jdk as well. xcode-select --install
 was run after the update to mojave

--
Ticket URL: <https://trac.macports.org/ticket/57255>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: Soprano needs Java

MacPorts
#57255: Soprano needs Java
----------------------+--------------------------------
  Reporter:  milomak  |      Owner:  (none)
      Type:  defect   |     Status:  new
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:  java xcode soprano
      Port:  soprano  |
----------------------+--------------------------------
Changes (by milomak):

 * Attachment "main.log" added.

 main.log

--
Ticket URL: <https://trac.macports.org/ticket/57255>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: Soprano needs Java
----------------------+--------------------------------
  Reporter:  milomak  |      Owner:  (none)
      Type:  defect   |     Status:  new
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:  java xcode soprano
      Port:  soprano  |
----------------------+--------------------------------

Comment (by mf2k):

 In the future, please use WikiFormatting.

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:1>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------
Changes (by mf2k):

 * cc: pixilla (removed)
 * status:  new => assigned
 * keywords:  java xcode soprano =>
 * owner:  (none) => pixilla


Old description:

> when i try to install soprano, the following error presents itself:
> $ sudo port install soprano
> --->  Computing dependencies for soprano
> --->  Configuring soprano
> Error: soprano requires the Java for Mac OS X development headers.
> Error: Make sure your Xcode installation is complete.
> Error: Failed to configure soprano: missing Java headers
> Error: See
> /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_soprano/soprano/main.log
> for details.
> Error: Follow https://guide.macports.org/#project.tickets to report a
> bug.
> Error: Processing of port soprano failed
>
> Java is installed:
> java --version
> java 11 2018-09-25
> Java(TM) SE Runtime Environment 18.9 (build 11+28)
> Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11+28, mixed mode)
>
> i've used installed the latest oracle jdk as well. xcode-select --install
> was run after the update to mojave
New description:

 when i try to install soprano, the following error presents itself:
 {{{
 $ sudo port install soprano
 --->  Computing dependencies for soprano
 --->  Configuring soprano
 Error: soprano requires the Java for Mac OS X development headers.
 Error: Make sure your Xcode installation is complete.
 Error: Failed to configure soprano: missing Java headers
 Error: See
 /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_soprano/soprano/main.log
 for details.
 Error: Follow https://guide.macports.org/#project.tickets to report a bug.
 Error: Processing of port soprano failed
 }}}
 Java is installed:
 {{{
 java --version
 java 11 2018-09-25
 Java(TM) SE Runtime Environment 18.9 (build 11+28)
 Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11+28, mixed mode)
 }}}
 i've used installed the latest oracle jdk as well. xcode-select --install
 was run after the update to mojave

--

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by mf2k):

 It looks like you only have the Java JRE installed. You need to installed
 the JDK.

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by milomak):

 I have reinstalled java. and as you can see from the below it is the jdk
 that is running.
 [https://www.oracle.com/technetwork/java/javase/downloads/jdk11-downloads-5066655.html
 oracle jdk11 dmg to be specific]
 {{{
 $ java --version
 java 11 2018-09-25
 Java(TM) SE Runtime Environment 18.9 (build 11+28)
 Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11+28, mixed mode)
 }}}
 {{{
 $ sudo /usr/libexec/java_home -V
 Matching Java Virtual Machines (1):
     11, x86_64: "Java SE 11"
 /Library/Java/JavaVirtualMachines/jdk-11.jdk/Contents/Home
 }}}


 and the error still persists:
 {{{
 $ sudo port install soprano -x11
 --->  Computing dependencies for soprano
 --->  Configuring soprano
 Error: soprano requires the Java for Mac OS X development headers.
 Error: Make sure your Xcode installation is complete.
 Error: Failed to configure soprano: missing Java headers
 Error: See
 /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_soprano/soprano/main.log
 for details.
 Error: Follow https://guide.macports.org/#project.tickets to report a bug.
 Error: Processing of port soprano failed
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:4>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by stanimura):

 The same error even with Java. Installing Java is not solution.
 The version of Java is the following:
 {{{
 $ sudo /usr/libexec/java_home -V
 Matching Java Virtual Machines (2):
     11, x86_64: "OpenJDK 11"
 /Library/Java/JavaVirtualMachines/jdk-11.jdk/Contents/Home
     1.8.0_121, x86_64:  "Java SE 8"
 /Library/Java/JavaVirtualMachines/jdk1.8.0_121.jdk/Contents/Home

 /Library/Java/JavaVirtualMachines/jdk-11.jdk/Contents/Home
 }}}

 The classical solution is to make symbolic link on
 /System/Library/Frameworks/JavaVM.framework/Headers, but it is not
 possbile on Mojave because of rootless system.

 However, soparno is succeded to build on Mojave simply after comment out
 pre-configure in Portfile.
 {{{
 # pre-configure {
 #    if {![file isfile
 "/System/Library/Frameworks/JavaVM.framework/Headers/jni.h"]} {
 #        ui_error "${name} requires the Java for Mac OS X development
 headers."
 #        if {${os.major} == 11} {
 #            ui_error "Download the Java Developer Package from:
 <http://support.apple.com/kb/DL1421>"
 #        } elseif {${os.major} == 10} {
 #            ui_error "Download the Java Developer Package from:
 <https://connect.apple.com/cgi-
 bin/WebObjects/MemberSite.woa/wa/getSoftware?bundleID=20719>"
 #        } elseif {${os.major} == 9} {
 #            ui_error "Download the Java Developer Package from:
 <https://connect.apple.com/cgi-
 bin/WebObjects/MemberSite.woa/wa/getSoftware?bundleID=20720>"
 #        } else {
 #            ui_error "Make sure your Xcode installation is complete."
 #        }
 #        return -code error "missing Java headers"
 #    }
 # }
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:5>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by milomak):

 where is the file located?

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:6>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by stanimura):

 Hi, milomak,
 Instead of editing Porfile directly, you can do
 {{{
 $ sudo port edit soprano
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:7>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by milomak):

 thanks. i see it seems to use vim.

 can i change it to nano?

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:8>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by stanimura):

 {{{
 man port
 }}}
 and search "edit", then you can find an example to use nano.

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:9>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: [Solved] Soprano needs Java (was: Soprano needs Java)

MacPorts
In reply to this post by MacPorts
#57255: [Solved] Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:10>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: [Solved] Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: [Solved] Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by milomak):

 added the following to ~/.bash_profile


 {{{
 export EDITOR=nano
 }}}

 then ran

 {{{
 source ~/.bash_profile
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:11>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: [Solved] Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: [Solved] Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by rlhamil):

 This worked for me: change the line in pre-configure that looks like

 {{{
      if {![file isfile
 "/System/Library/Frameworks/JavaVM.framework/Headers/jni.h"]} {
 }}}
 to
 {{{
      if {![file isfile
 "/System/Library/Frameworks/JavaVM.framework/Headers/jni.h"] && ![file
 isfile
 "/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/System/Library/Frameworks/JavaVM.framework/Versions/A/Headers/jni.h"]}
 {
 }}}

 (be sure to get all of the 2nd line).  This would allow the file to be
 found in either location (the latter being where it is on Mojave).

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:12>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: [Solved] Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: [Solved] Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by Liontooth):

 rlhamil's fix works for Mojave; how do we get it merged?

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:13>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: [Solved] Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: [Solved] Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by mf2k):

 [wiki:WorkingWithGit#pr Submit a pull request]

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:14>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: [Solved] Soprano needs Java

MacPorts
In reply to this post by MacPorts
#57255: [Solved] Soprano needs Java
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by jjstickel):

 Replying to [comment:14 mf2k]:
 > [wiki:WorkingWithGit#pr Submit a pull request]

 OR provide a patch? PRs can be a big hurdle for potentially new
 contributors.

 Anyway, I created a PR:  https://github.com/macports/macports-
 ports/pull/2946

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:17>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: soprano @2.9.4: Error: soprano requires the Java for Mac OS X development headers. (was: [Solved] Soprano needs Java)

MacPorts
In reply to this post by MacPorts
#57255: soprano @2.9.4: Error: soprano requires the Java for Mac OS X development
headers.
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by ryandesign):

 This is still a problem, even
 [https://build.macports.org/builders/ports-10.14_x86_64-builder/builds/15298/steps
 /install-port/logs/stdio on the buildbot workers].

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:18>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: soprano @2.9.4: Error: soprano requires the Java for Mac OS X development headers.

MacPorts
In reply to this post by MacPorts
#57255: soprano @2.9.4: Error: soprano requires the Java for Mac OS X development
headers.
----------------------+----------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:           |   Keywords:
      Port:  soprano  |
----------------------+----------------------

Comment (by jjstickel):

 Replying to [comment:18 ryandesign]:
 > This is still a problem

 The pull request I submitted fixes it. It just needs to be merged.

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:19>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #57255: soprano @2.9.4: Error: soprano requires the Java for Mac OS X development headers.

MacPorts
In reply to this post by MacPorts
#57255: soprano @2.9.4: Error: soprano requires the Java for Mac OS X development
headers.
----------------------+---------------------
  Reporter:  milomak  |      Owner:  pixilla
      Type:  defect   |     Status:  closed
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.5.4
Resolution:  fixed    |   Keywords:
      Port:  soprano  |
----------------------+---------------------
Changes (by jjstickel):

 * status:  assigned => closed
 * resolution:   => fixed


Comment:

 In [changeset:"856ef7c88cfdd12474c299b70adf4cf912a54085/macports-ports"
 856ef7c88cfdd12474c299b70adf4cf912a54085/macports-ports] (master):
 {{{
 #!ConfigurableCommitTicketReference repository="macports-ports"
 revision="856ef7c88cfdd12474c299b70adf4cf912a54085"
 soprano: fix JDK location for mojave

 Closes: https://trac.macports.org/ticket/57255
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/57255#comment:20>
MacPorts <https://www.macports.org/>
Ports system for macOS