[MacPorts] #56336: Failed to configure llvm-5.0: configure failure: command execution failed

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

[MacPorts] #56336: Failed to configure llvm-5.0: configure failure: command execution failed

MacPorts
#56336: Failed to configure llvm-5.0: configure failure: command execution failed
--------------------+----------------------
 Reporter:  har5ha  |      Owner:  (none)
     Type:  defect  |     Status:  new
 Priority:  Normal  |  Milestone:
Component:  ports   |    Version:  2.4.3
 Keywords:  lion    |       Port:  llvm-5.0
--------------------+----------------------
 I am having the following problem when trying to upgrade **gnuradio**

 I would be very grateful if somebody could point me in the right
 direction.

 Thanks in Advance!



 OS : **Mac OSX : 10.7.5 [Lion]**

 MacPorts: **2.4.3**


 {{{
 $sudo port upgrade gnuradio
 Warning: All compilers are either blacklisted or unavailable; defaulting
 to first fallback option
 Warning: All compilers are either blacklisted or unavailable; defaulting
 to first fallback option
 --->  Computing dependencies for llvm-5.0
 --->  Fetching distfiles for llvm-5.0
 --->  Verifying checksums for llvm-5.0
 --->  Extracting llvm-5.0
 --->  Applying patches to llvm-5.0
 --->  Configuring llvm-5.0
 Error: Failed to configure llvm-5.0: configure failure: command execution
 failed
 Error: See
 /macports/var/macports/logs/_macports_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-5.0/llvm-5.0/main.log
 for details.
 Error: Problem while installing llvm-5.0
 Error: Follow https://guide.macports.org/#project.tickets to report a bug.
 }}}


 **Partial main.log file :**


 {{{
 :info:patch patching file lib/Fuzzer/CMakeLists.txt
 :debug:patch Privilege de-escalation not attempted as not running as root.
 :debug:configure configure phase started at Sat Apr 21 21:57:55 IST 2018
 :notice:configure --->  Configuring llvm-5.0
 :debug:configure Preferred compilers: clang llvm-gcc-4.2 macports-
 clang-4.0 macports-clang-3.9 macports-clang-3.7 macports-clang-3.4
 macports-llvm-gcc-4.2 apple-gcc-4.2
 :debug:configure Using compiler 'MacPorts Clang 4.0'
 :debug:configure Executing proc-pre-org.macports.configure-configure-0
 :debug:configure Active variants check for source-type install considers
 depends_fetch depends_extract depends_lib depends_build depends_run: xz
 libedit libffi ncurses xar zlib libcxx cmake cctools clang-4.0 perl5
 llvm_select
 :debug:configure Executing proc-pre-org.macports.configure-configure-1
 :debug:configure Executing proc-pre-org.macports.configure-configure-2
 :debug:configure Executing proc-pre-org.macports.configure-configure-3
 :debug:configure Executing org.macports.configure (llvm-5.0)
 :debug:configure Environment:
 :debug:configure CC='/macports/bin/clang-mp-4.0'
 :debug:configure CC_PRINT_OPTIONS='YES'
 :debug:configure
 CC_PRINT_OPTIONS_FILE='/macports/var/macports/build/_macports_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-5.0/llvm-5.0/work/.CC_PRINT_OPTIONS'
 :debug:configure CFLAGS='-pipe -Os'
 :debug:configure CPATH='/macports/include'
 :debug:configure CPPFLAGS='-I/macports/include'
 :debug:configure CXX='/macports/bin/clang++-mp-4.0'
 :debug:configure CXXFLAGS='-pipe -Os -std=c++11 -stdlib=libc++'
 :debug:configure F77FLAGS='-m64'
 :debug:configure F90FLAGS='-pipe -Os -m64'
 :debug:configure FCFLAGS='-pipe -Os -m64'
 :debug:configure FFLAGS='-pipe -Os'
 :debug:configure INSTALL='/usr/bin/install -c'
 :debug:configure LDFLAGS='-L/macports/lib
 -Wl,-headerpad_max_install_names'
 :debug:configure LIBRARY_PATH='/macports/lib'
 :debug:configure MACOSX_DEPLOYMENT_TARGET='10.7'
 :debug:configure OBJC='/macports/bin/clang-mp-4.0'
 :debug:configure OBJCFLAGS='-pipe -Os'
 :debug:configure OBJCXX='/macports/bin/clang++-mp-4.0'
 :debug:configure OBJCXXFLAGS='-pipe -Os -std=c++11 -stdlib=libc++'
 :info:configure Executing:  cd
 "/macports/var/macports/build/_macports_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-5.0/llvm-5.0/work/build"
 && /macports/bin/cmake -DCMAKE_INSTALL_PREFIX='/macports/libexec/llvm-5.0'
 -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON
 -DCMAKE_C_COMPILER="$CC" -DCMAKE_COLOR_MAKEFILE=ON
 -DCMAKE_CXX_COMPILER="$CXX" -DCMAKE_FIND_FRAMEWORK=LAST
 -DCMAKE_INSTALL_NAME_DIR=/macports/libexec/llvm-5.0/lib
 -DCMAKE_INSTALL_RPATH=/macports/libexec/llvm-5.0/lib
 -DCMAKE_MODULE_PATH=/macports/share/cmake/Modules
 -DCMAKE_SYSTEM_PREFIX_PATH="/macports/libexec/llvm-5.0;/macports;/usr"
 -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_POLICY_DEFAULT_CMP0025=NEW -Wno-dev
 -DCMAKE_SYSTEM_PREFIX_PATH="/macports/libexec/llvm-5.0;/macports;/usr"
 -DLLVM_LINK_LLVM_DYLIB=ON -DLLVM_ENABLE_ASSERTIONS=OFF
 -DLLVM_ENABLE_RTTI=ON -DLLVM_INCLUDE_TESTS=OFF -DLLVM_INCLUDE_EXAMPLES=OFF
 -DLLVM_ENABLE_FFI=ON -DLLVM_BINDINGS_LIST=none -DFFI_INCLUDE_DIR=`pkg-
 config --cflags-only-I libffi | sed 's/-I//'`
 -DFFI_LIBRARY_DIR=/macports/lib -DCMAKE_LIBTOOL=/macports/bin/libtool
 -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG"
 -DCMAKE_OSX_ARCHITECTURES="x86_64" -DCMAKE_OSX_DEPLOYMENT_TARGET="10.7"
 -DCMAKE_OSX_SYSROOT="/" ../llvm-5.0.1.src
 :debug:configure system:  cd
 "/macports/var/macports/build/_macports_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-5.0/llvm-5.0/work/build"
 && /macports/bin/cmake -DCMAKE_INSTALL_PREFIX='/macports/libexec/llvm-5.0'
 -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON
 -DCMAKE_C_COMPILER="$CC" -DCMAKE_COLOR_MAKEFILE=ON
 -DCMAKE_CXX_COMPILER="$CXX" -DCMAKE_FIND_FRAMEWORK=LAST
 -DCMAKE_INSTALL_NAME_DIR=/macports/libexec/llvm-5.0/lib
 -DCMAKE_INSTALL_RPATH=/macports/libexec/llvm-5.0/lib
 -DCMAKE_MODULE_PATH=/macports/share/cmake/Modules
 -DCMAKE_SYSTEM_PREFIX_PATH="/macports/libexec/llvm-5.0;/macports;/usr"
 -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_POLICY_DEFAULT_CMP0025=NEW -Wno-dev
 -DCMAKE_SYSTEM_PREFIX_PATH="/macports/libexec/llvm-5.0;/macports;/usr"
 -DLLVM_LINK_LLVM_DYLIB=ON -DLLVM_ENABLE_ASSERTIONS=OFF
 -DLLVM_ENABLE_RTTI=ON -DLLVM_INCLUDE_TESTS=OFF -DLLVM_INCLUDE_EXAMPLES=OFF
 -DLLVM_ENABLE_FFI=ON -DLLVM_BINDINGS_LIST=none -DFFI_INCLUDE_DIR=`pkg-
 config --cflags-only-I libffi | sed 's/-I//'`
 -DFFI_LIBRARY_DIR=/macports/lib -DCMAKE_LIBTOOL=/macports/bin/libtool
 -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG"
 -DCMAKE_OSX_ARCHITECTURES="x86_64" -DCMAKE_OSX_DEPLOYMENT_TARGET="10.7"
 -DCMAKE_OSX_SYSROOT="/" ../llvm-5.0.1.src
 :info:configure -- The C compiler identification is unknown
 :info:configure -- The CXX compiler identification is unknown
 :info:configure -- The ASM compiler identification is unknown
 :info:configure -- Found assembler: /macports/bin/clang-mp-4.0
 :info:configure -- Check for working C compiler: /macports/bin/clang-
 mp-4.0
 :info:configure -- Check for working C compiler: /macports/bin/clang-
 mp-4.0 -- broken
 :info:configure CMake Error at
 /macports/share/cmake-3.11/Modules/CMakeTestCCompiler.cmake:52 (message):
 :info:configure   The C compiler
 :info:configure     "/macports/bin/clang-mp-4.0"
 :info:configure   is not able to compile a simple test program.
 :info:configure   It fails with the following output:
 :info:configure     Change Dir:
 /macports/var/macports/build/_macports_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-5.0/llvm-5.0/work/build/CMakeFiles/CMakeTmp
 :info:configure
 :info:configure     Run Build Command:"/macports/bin/gmake"
 "cmTC_20327/fast"
 :info:configure     /macports/bin/gmake -f
 CMakeFiles/cmTC_20327.dir/build.make CMakeFiles/cmTC_20327.dir/build
 :info:configure     gmake[1]: Entering directory
 '/macports/var/macports/build/_macports_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-5.0/llvm-5.0/work/build/CMakeFiles/CMakeTmp'
 :info:configure     Building C object
 CMakeFiles/cmTC_20327.dir/testCCompiler.c.o
 :info:configure     /macports/bin/clang-mp-4.0   -pipe -Os  -arch x86_64
 -o CMakeFiles/cmTC_20327.dir/testCCompiler.c.o   -c
 /macports/var/macports/build/_macports_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-5.0/llvm-5.0/work/build/CMakeFiles/CMakeTmp/testCCompiler.c
 :info:configure     2018-04-21 21:59:36.090 xcodebuild[94756:a0b] [MT]
 DVTAssertions: ASSERTION FAILURE in
 /SourceCache/DVTFoundation/DVTFoundation-2091/Framework/Classes/FilePaths/DVTFilePath.m:379
 :info:configure     Details:  fsrep is absolute (starts with /)
 ('/macports/libexec/llvm-4.0/bin/clang') parentPath must be nil but it is
 not
 ('<DVTFilePath:0x40041f3e0:'/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin'>')
 :info:configure     Object:   <DVTFilePath>
 :info:configure     Method:
 +_filePathForParent:fileSystemRepresentation:length:allowCreation:
 :info:configure     Thread:   <NSThread: 0x40010a220>{name = (null), num =
 1}
 :info:configure     Hints: None
 :info:configure     Backtrace:
 :info:configure       0  0x0000000107d996b3 -[DVTAssertionHandler
 handleFailureInMethod:object:fileName:lineNumber:messageFormat:arguments:]
 (in DVTFoundation)
 :info:configure       1  0x0000000107d994e4 _DVTAssertionFailureHandler
 (in DVTFoundation)
 :info:configure       2  0x0000000107d1c32f +[DVTFilePath
 _filePathForParent:fileSystemRepresentation:length:allowCreation:] (in
 DVTFoundation)
 :info:configure       3  0x0000000107d1be15 +[DVTFilePath
 _filePathForParent:pathString:] (in DVTFoundation)
 :info:configure       4  0x0000000107d502ad -[DVTSearchPath
 pathForFileWithRelativePathString:] (in DVTFoundation)
 :info:configure       5  0x000000010859d798 -[Xcode3CommandLineBuildTool
 _printPathToExecutableAndExit] (in Xcode3Core)
 :info:configure       6  0x000000010859f834 -[Xcode3CommandLineBuildTool
 run] (in Xcode3Core)
 :info:configure       7  0x0000000107d119a6 (in xcodebuild)
 :info:configure       8  0x0000000107d11770 (in xcodebuild)
 :info:configure
 /Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild fails with 6
 - Device not configured
 :info:configure     CMakeFiles/cmTC_20327.dir/build.make:65: recipe for
 target 'CMakeFiles/cmTC_20327.dir/testCCompiler.c.o' failed
 :info:configure     gmake[1]: ***
 [CMakeFiles/cmTC_20327.dir/testCCompiler.c.o] Error 69
 :info:configure     gmake[1]: Leaving directory
 '/macports/var/macports/build/_macports_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-5.0/llvm-5.0/work/build/CMakeFiles/CMakeTmp'
 :info:configure     Makefile:126: recipe for target 'cmTC_20327/fast'
 failed
 :info:configure     gmake: *** [cmTC_20327/fast] Error 2
 :info:configure
 :info:configure
 :info:configure   CMake will not be able to correctly generate this
 project.
 :info:configure Call Stack (most recent call first):
 :info:configure   CMakeLists.txt:54 (project)
 :info:configure -- Configuring incomplete, errors occurred!
 :info:configure See also
 "/macports/var/macports/build/_macports_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-5.0/llvm-5.0/work/build/CMakeFiles/CMakeOutput.log".
 :info:configure See also
 "/macports/var/macports/build/_macports_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-5.0/llvm-5.0/work/build/CMakeFiles/CMakeError.log".
 :info:configure Command failed:  cd
 "/macports/var/macports/build/_macports_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-5.0/llvm-5.0/work/build"
 && /macports/bin/cmake -DCMAKE_INSTALL_PREFIX='/macports/libexec/llvm-5.0'
 -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON
 -DCMAKE_C_COMPILER="$CC" -DCMAKE_COLOR_MAKEFILE=ON
 -DCMAKE_CXX_COMPILER="$CXX" -DCMAKE_FIND_FRAMEWORK=LAST
 -DCMAKE_INSTALL_NAME_DIR=/macports/libexec/llvm-5.0/lib
 -DCMAKE_INSTALL_RPATH=/macports/libexec/llvm-5.0/lib
 -DCMAKE_MODULE_PATH=/macports/share/cmake/Modules
 -DCMAKE_SYSTEM_PREFIX_PATH="/macports/libexec/llvm-5.0;/macports;/usr"
 -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_POLICY_DEFAULT_CMP0025=NEW -Wno-dev
 -DCMAKE_SYSTEM_PREFIX_PATH="/macports/libexec/llvm-5.0;/macports;/usr"
 -DLLVM_LINK_LLVM_DYLIB=ON -DLLVM_ENABLE_ASSERTIONS=OFF
 -DLLVM_ENABLE_RTTI=ON -DLLVM_INCLUDE_TESTS=OFF -DLLVM_INCLUDE_EXAMPLES=OFF
 -DLLVM_ENABLE_FFI=ON -DLLVM_BINDINGS_LIST=none -DFFI_INCLUDE_DIR=`pkg-
 config --cflags-only-I libffi | sed 's/-I//'`
 -DFFI_LIBRARY_DIR=/macports/lib -DCMAKE_LIBTOOL=/macports/bin/libtool
 -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG"
 -DCMAKE_OSX_ARCHITECTURES="x86_64" -DCMAKE_OSX_DEPLOYMENT_TARGET="10.7"
 -DCMAKE_OSX_SYSROOT="/" ../llvm-5.0.1.src
 :info:configure Exit code: 1
 :error:configure Failed to configure llvm-5.0: configure failure: command
 execution failed
 :debug:configure Error code: NONE
 :debug:configure Backtrace: configure failure: command execution failed
 :debug:configure     while executing
 :debug:configure "$procedure $targetname"
 :error:configure See
 /macports/var/macports/logs/_macports_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-5.0/llvm-5.0/main.log
 for details.


 }}}



 Attaching the full llvm-5.0/main.log below.

--
Ticket URL: <https://trac.macports.org/ticket/56336>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56336: Failed to configure llvm-5.0: configure failure: command execution failed

MacPorts
#56336: Failed to configure llvm-5.0: configure failure: command execution failed
-----------------------+--------------------
  Reporter:  har5ha    |      Owner:  (none)
      Type:  defect    |     Status:  new
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.4.3
Resolution:            |   Keywords:  lion
      Port:  llvm-5.0  |
-----------------------+--------------------
Changes (by har5ha):

 * Attachment "llvm-5.0_main.log" added.


--
Ticket URL: <https://trac.macports.org/ticket/56336>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56336: Failed to configure llvm-5.0: configure failure: command execution failed

MacPorts
In reply to this post by MacPorts
#56336: Failed to configure llvm-5.0: configure failure: command execution failed
-----------------------+----------------------
  Reporter:  har5ha    |      Owner:  jeremyhu
      Type:  defect    |     Status:  assigned
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.4.3
Resolution:            |   Keywords:  lion
      Port:  llvm-5.0  |
-----------------------+----------------------
Changes (by mf2k):

 * owner:  (none) => jeremyhu
 * cc: jeremyhu (removed)
 * status:  new => assigned


--
Ticket URL: <https://trac.macports.org/ticket/56336#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56336: Failed to configure llvm-5.0: configure failure: command execution failed

MacPorts
In reply to this post by MacPorts
#56336: Failed to configure llvm-5.0: configure failure: command execution failed
-----------------------+----------------------
  Reporter:  har5ha    |      Owner:  jeremyhu
      Type:  defect    |     Status:  assigned
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.4.3
Resolution:            |   Keywords:  lion
      Port:  llvm-5.0  |
-----------------------+----------------------

Comment (by kencu):

 Could you take a moment to give me the output of the following?
 {{{
 xcode-select -print-path
 }}}
 {{{
 xcode-select -version
 }}}
 {{{
 which xcodebuild
 }}}
 {{{
 xcodebuild -version
 }}}

 You should see something like:
 {{{
 $ xcode-select -print-path
 /Applications/Xcode.app/Contents/Developer
 $ xcode-select -version
 xcode-select version 2308.
 $ which xcodebuild
 /usr/bin/xcodebuild
 $ xcodebuild -version
 Xcode 4.6.3
 Build version 4H1503
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/56336#comment:4>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56336: Failed to configure llvm-5.0: configure failure: command execution failed

MacPorts
In reply to this post by MacPorts
#56336: Failed to configure llvm-5.0: configure failure: command execution failed
-----------------------+----------------------
  Reporter:  har5ha    |      Owner:  jeremyhu
      Type:  defect    |     Status:  assigned
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.4.3
Resolution:            |   Keywords:  lion
      Port:  llvm-5.0  |
-----------------------+----------------------

Comment (by har5ha):

 Thanks for your help!, I really appreciate it.


 The following is the output on my System :

 {{{
 $xcode-select -print-path
 /Applications/Xcode.app/Contents/Developer

 $xcode-select -version
 xcode-select version 2003.

 $which xcodebuild
 /usr/bin/xcodebuild

 $xcodebuild -version
 Xcode 4.6.3
 Build version 4H1503
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/56336#comment:5>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56336: Failed to configure llvm-5.0: configure failure: command execution failed

MacPorts
In reply to this post by MacPorts
#56336: Failed to configure llvm-5.0: configure failure: command execution failed
-----------------------+----------------------
  Reporter:  har5ha    |      Owner:  jeremyhu
      Type:  defect    |     Status:  assigned
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.4.3
Resolution:            |   Keywords:  lion
      Port:  llvm-5.0  |
-----------------------+----------------------

Comment (by kencu):

 I see your `xcode-select` has an older version than mine. My first thought
 is that the command-line tools you have installed in `/usr/bin` are out of
 date compared to your `Xcode` version. You can check this from Xcode ->
 Preferences -> Downloads -> Components.

 When i do that now, it says the certificate is invalid, though -- I forget
 now how I got around that issue.

 I do have llvm-5.0 installed on 10.7:
 {{{
 $ port -v installed llvm-5.0
 The following ports are currently installed:
   llvm-5.0 @5.0.1_0 (active) platform='darwin 11' archs='x86_64'
 date='2017-12-25T02:50:07-0800'
 }}}
 which I most likely installed on this machine from a pre-built binary from
 MacPorts, which you can't do due to your non-standard MacPorts
 installation directory.

 Your life would be a lot easier if you installed MacPorts in `/opt/local`,
 which is the default; then you could install pre-built binaries as well,
 and save hundreds of hours in compiling time. Something to ponder.

--
Ticket URL: <https://trac.macports.org/ticket/56336#comment:6>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56336: Failed to configure llvm-5.0: configure failure: command execution failed

MacPorts
In reply to this post by MacPorts
#56336: Failed to configure llvm-5.0: configure failure: command execution failed
-----------------------+----------------------
  Reporter:  har5ha    |      Owner:  jeremyhu
      Type:  defect    |     Status:  assigned
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.4.3
Resolution:            |   Keywords:  lion
      Port:  llvm-5.0  |
-----------------------+----------------------

Comment (by pmetzger):

 Har5ha, do you think you could try kencu's suggestion (moving macports to
 /opt/local) and seeing if your problem goes away?

--
Ticket URL: <https://trac.macports.org/ticket/56336#comment:7>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56336: Failed to configure llvm-5.0: configure failure: command execution failed

MacPorts
In reply to this post by MacPorts
#56336: Failed to configure llvm-5.0: configure failure: command execution failed
-----------------------+----------------------
  Reporter:  har5ha    |      Owner:  jeremyhu
      Type:  defect    |     Status:  closed
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.4.3
Resolution:  fixed     |   Keywords:  lion
      Port:  llvm-5.0  |
-----------------------+----------------------
Changes (by kencu):

 * status:  assigned => closed
 * resolution:   => fixed


Comment:

 I can't replicate this and all clang versions build and work. Please
 reopen if this is still an issue.

--
Ticket URL: <https://trac.macports.org/ticket/56336#comment:8>
MacPorts <https://www.macports.org/>
Ports system for macOS