[MacPorts] #56297: bind9 @9.12.1_0 does not work on my High Sierra

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[MacPorts] #56297: bind9 @9.12.1_0 does not work on my High Sierra

MacPorts
#56297: bind9 @9.12.1_0 does not work on my High Sierra
--------------------+--------------------
 Reporter:  inquil  |      Owner:  (none)
     Type:  defect  |     Status:  new
 Priority:  Normal  |  Milestone:
Component:  ports   |    Version:
 Keywords:          |       Port:
--------------------+--------------------
 bind9 @9.12.1_0 does not work on my High Sierra, log message is:

 network: error: could not listen on UDP socket: permission denied

 I rolled back to bind9 @9.12.0_0 and it works with no problem

--
Ticket URL: <https://trac.macports.org/ticket/56297>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56297: bind9 @9.12.1_0 does not work on my High Sierra

MacPorts
#56297: bind9 @9.12.1_0 does not work on my High Sierra
---------------------+------------------------
  Reporter:  inquil  |      Owner:  danielluke
      Type:  defect  |     Status:  assigned
  Priority:  Normal  |  Milestone:
 Component:  ports   |    Version:
Resolution:          |   Keywords:
      Port:  bind9   |
---------------------+------------------------
Changes (by raimue):

 * owner:  (none) => danielluke
 * status:  new => assigned
 * port:   => bind9


--
Ticket URL: <https://trac.macports.org/ticket/56297#comment:1>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56297: bind9 @9.12.1_0 does not work on my High Sierra

MacPorts
In reply to this post by MacPorts
#56297: bind9 @9.12.1_0 does not work on my High Sierra
---------------------+------------------------
  Reporter:  inquil  |      Owner:  danielluke
      Type:  defect  |     Status:  assigned
  Priority:  Normal  |  Milestone:
 Component:  ports   |    Version:
Resolution:          |   Keywords:
      Port:  bind9   |
---------------------+------------------------
Description changed by ryandesign:

Old description:

> bind9 @9.12.1_0 does not work on my High Sierra, log message is:
>
> network: error: could not listen on UDP socket: permission denied
>
> I rolled back to bind9 @9.12.0_0 and it works with no problem

New description:

 bind9 @9.12.1_0 does not work on my High Sierra, log message is:

 {{{
 network: error: could not listen on UDP socket: permission denied
 }}}

 I rolled back to bind9 @9.12.0_0 and it works with no problem

--

--
Ticket URL: <https://trac.macports.org/ticket/56297#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56297: bind9 @9.12.1_0 does not work on my High Sierra

MacPorts
In reply to this post by MacPorts
#56297: bind9 @9.12.1_0 does not work on my High Sierra
---------------------+------------------------
  Reporter:  inquil  |      Owner:  danielluke
      Type:  defect  |     Status:  assigned
  Priority:  Normal  |  Milestone:
 Component:  ports   |    Version:
Resolution:          |   Keywords:
      Port:  bind9   |
---------------------+------------------------

Comment (by danielluke):

 How are you starting bind9? That sounds like your 9.12.1 is not being
 started as root, but 9.12.0 is. Additionally what does your listen-on
 (and/or listen-on-v6) directive look like in your named.conf file?

--
Ticket URL: <https://trac.macports.org/ticket/56297#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56297: bind9 @9.12.1_0 does not work on my High Sierra

MacPorts
In reply to this post by MacPorts
#56297: bind9 @9.12.1_0 does not work on my High Sierra
---------------------+------------------------
  Reporter:  inquil  |      Owner:  danielluke
      Type:  defect  |     Status:  assigned
  Priority:  Normal  |  Milestone:
 Component:  ports   |    Version:
Resolution:          |   Keywords:
      Port:  bind9   |
---------------------+------------------------

Comment (by inquil):

 Hi,

 a) my script for launching it

 cat /Library/LaunchDaemons/org.isc.named.plist
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN"
 "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
 <plist version="1.0">
 <dict>
         <key>Disabled</key>
         <false/>
         <key>EnableTransactions</key>
         <true/>
         <key>Label</key>
         <string>org.isc.named</string>
         <key>OnDemand</key>
         <false/>
         <key>ProgramArguments</key>
         <array>
                 <string>/usr/local/sbin/named</string>
                 <string>-f</string>
         </array>
         <key>ServiceIPC</key>
         <false/>
 </dict>
 </plist>

 b)  listen-on { any; };

 Regards,

 Carlos

--
Ticket URL: <https://trac.macports.org/ticket/56297#comment:4>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56297: bind9 @9.12.1_0 does not work on my High Sierra

MacPorts
In reply to this post by MacPorts
#56297: bind9 @9.12.1_0 does not work on my High Sierra
---------------------+------------------------
  Reporter:  inquil  |      Owner:  danielluke
      Type:  defect  |     Status:  assigned
  Priority:  Normal  |  Milestone:
 Component:  ports   |    Version:
Resolution:          |   Keywords:
      Port:  bind9   |
---------------------+------------------------

Comment (by danielluke):

 Is your macports prefix set to /usr/local? The default macports prefix is
 /opt/local but that startup script is trying to run /usr/local/sbin/named.
 You may also want to verify that when you've stopped bind9 @9.12.0 that
 nothing has port 53 open (`sudo lsof -i :53`).

--
Ticket URL: <https://trac.macports.org/ticket/56297#comment:5>
MacPorts <https://www.macports.org/>
Ports system for macOS