[MacPorts] #56264: py34-matplotlib: missing dependency py34-kiwisolver

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[MacPorts] #56264: py34-matplotlib: missing dependency py34-kiwisolver

MacPorts
#56264: py34-matplotlib: missing dependency py34-kiwisolver
--------------------+---------------------------------------------
 Reporter:  mojca   |      Owner:  seanfarley
     Type:  defect  |     Status:  assigned
 Priority:  Normal  |  Milestone:
Component:  ports   |    Version:
 Keywords:          |       Port:  py34-kiwisolver py34-matplotlib
--------------------+---------------------------------------------
 The `py34-matplotlib` subport is missing a dependency `py34-kiwisolver`.
 We should decide whether to add that subport or (preferably?) move
 `py34-matplotlib` and and all dependent (sub)ports to `py-graveyard`.

 See #56220.

--
Ticket URL: <https://trac.macports.org/ticket/56264>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56264: py34-matplotlib: missing dependency py34-kiwisolver

MacPorts
#56264: py34-matplotlib: missing dependency py34-kiwisolver
----------------------------------------------+------------------------
  Reporter:  mojca                            |      Owner:  seanfarley
      Type:  defect                           |     Status:  assigned
  Priority:  Normal                           |  Milestone:
 Component:  ports                            |    Version:
Resolution:                                   |   Keywords:
      Port:  py34-kiwisolver py34-matplotlib  |
----------------------------------------------+------------------------

Comment (by EJFielding):

 Matplotlib is a key part of using Python. If the py34-matplotlib is not
 supported, then we need to warn people to move to python35 or python36.

--
Ticket URL: <https://trac.macports.org/ticket/56264#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #56264: py34-matplotlib: missing dependency py34-kiwisolver

MacPorts
In reply to this post by MacPorts
#56264: py34-matplotlib: missing dependency py34-kiwisolver
----------------------------------------------+------------------------
  Reporter:  mojca                            |      Owner:  seanfarley
      Type:  defect                           |     Status:  closed
  Priority:  Normal                           |  Milestone:
 Component:  ports                            |    Version:
Resolution:  fixed                            |   Keywords:
      Port:  py34-kiwisolver py34-matplotlib  |
----------------------------------------------+------------------------
Changes (by mojca):

 * status:  assigned => closed
 * resolution:   => fixed


Comment:

 I was contemplating what to do and decided to fix it in
 [changeset:df094a9f7eda303b9f4fa388473a7682a7fe80af/macports-ports
 df094a9] because removing 34 subports will require a bit more effort and
 will take longer than just a few days.

--
Ticket URL: <https://trac.macports.org/ticket/56264#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS