[MacPorts] #55993: osmocore @20180305: error: unknown type name 'clockid_t'; did you mean 'clock_t'?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[MacPorts] #55993: osmocore @20180305: error: unknown type name 'clockid_t'; did you mean 'clock_t'?

MacPorts
#55993: osmocore @20180305: error: unknown type name 'clockid_t'; did you mean
'clock_t'?
------------------------+-----------------------
 Reporter:  ryandesign  |      Owner:  michaelld
     Type:  defect      |     Status:  new
 Priority:  Normal      |  Milestone:
Component:  ports       |    Version:
 Keywords:              |       Port:  osmocore
------------------------+-----------------------
 osmocore fails to build on El Capitan and earlier:

 {{{
 error: unknown type name 'clockid_t'; did you mean 'clock_t'?
 }}}

 https://build.macports.org/builders/ports-10.11_x86_64-builder/builds/49781/steps
 /install-port/logs/stdio

--
Ticket URL: <https://trac.macports.org/ticket/55993>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #55993: osmocore @20180305: error: unknown type name 'clockid_t'; did you mean 'clock_t'?

MacPorts
#55993: osmocore @20180305: error: unknown type name 'clockid_t'; did you mean
'clock_t'?
-------------------------+-----------------------
  Reporter:  ryandesign  |      Owner:  michaelld
      Type:  defect      |     Status:  new
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  osmocore    |
-------------------------+-----------------------

Comment (by michaelld):

 Can I get access to these build logs automatically? I think I used to get
 them, but then they stopped for some reason. They provided useful
 feedback!

--
Ticket URL: <https://trac.macports.org/ticket/55993#comment:1>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #55993: osmocore @20180305: error: unknown type name 'clockid_t'; did you mean 'clock_t'?

MacPorts
In reply to this post by MacPorts
#55993: osmocore @20180305: error: unknown type name 'clockid_t'; did you mean
'clock_t'?
-------------------------+-----------------------
  Reporter:  ryandesign  |      Owner:  michaelld
      Type:  defect      |     Status:  new
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  osmocore    |
-------------------------+-----------------------

Comment (by ryandesign):

 The emails are being sent (see https://lists.macports.org/pipermail
 /macports-builds/) but many people including me aren't receiving them. I
 haven't investigated what's going wrong with that.

--
Ticket URL: <https://trac.macports.org/ticket/55993#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #55993: osmocore @20180305: error: unknown type name 'clockid_t'; did you mean 'clock_t'?

MacPorts
In reply to this post by MacPorts
#55993: osmocore @20180305: error: unknown type name 'clockid_t'; did you mean
'clock_t'?
-------------------------+-----------------------
  Reporter:  ryandesign  |      Owner:  michaelld
      Type:  defect      |     Status:  closed
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:  fixed       |   Keywords:
      Port:  osmocore    |
-------------------------+-----------------------
Changes (by michaelld):

 * status:  new => closed
 * resolution:   => fixed


Comment:

 In [changeset:"77280c4ca81e99ad76782fb8479293cf0ca84a43/macports-ports"
 77280c4ca81e99ad76782fb8479293cf0ca84a43/macports-ports]:
 {{{
 #!ConfigurableCommitTicketReference repository="macports-ports"
 revision="77280c4ca81e99ad76782fb8479293cf0ca84a43"
 osmocore: fix clock_gettime patch to work more robustly

 Closes: https://trac.macports.org/ticket/55993
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/55993#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #55993: osmocore @20180305: error: unknown type name 'clockid_t'; did you mean 'clock_t'?

MacPorts
In reply to this post by MacPorts
#55993: osmocore @20180305: error: unknown type name 'clockid_t'; did you mean
'clock_t'?
-------------------------+-----------------------
  Reporter:  ryandesign  |      Owner:  michaelld
      Type:  defect      |     Status:  closed
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:  fixed       |   Keywords:
      Port:  osmocore    |
-------------------------+-----------------------

Comment (by michaelld):

 This time tested on 10.8 as well as 10.12 and 10.13.

 I will enquire upstream about this issue, since my changes had to be
 pretty extensive to get the various clock_gettime parts to work.

--
Ticket URL: <https://trac.macports.org/ticket/55993#comment:4>
MacPorts <https://www.macports.org/>
Ports system for macOS