Quantcast

[MacPorts] #54179: gv 3.7.4 fails to open correctly

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[MacPorts] #54179: gv 3.7.4 fails to open correctly

MacPorts
#54179: gv 3.7.4 fails to open correctly
----------------------+-----------------
 Reporter:  o12johns  |      Owner:
     Type:  defect    |     Status:  new
 Priority:  Normal    |  Milestone:
Component:  ports     |    Version:
 Keywords:            |       Port:  gv
----------------------+-----------------
 Up to date port installation.  E.g., xfig works correctly.  But gv does
 not.

 AeroNew:~ ojohns$ gv ~/Desktop/body-cone-earth.eps

 produces panel labeled
 GHOSTSCRIPT MESSAGES
 with the text:

 Unknown device: x11
   ./base/gsicc_manage.c:1126: gsicc_open_search(): Could not find
 default_gray.icc
 | ./base/gsicc_manage.c:1754: gsicc_set_device_profile(): cannot find
 device profile
 Unrecoverable error: unknownerror in .special_op
 Operand stack:
     defaultdevice
 Unrecoverable error: undefined in .uninstallpagedevice
 Operand stack:
     defaultdevice

 Then gv program comes up, but with empty display.  Attempts to OPEN the
 eps file from
 within gv result in the same message as above.

--
Ticket URL: <https://trac.macports.org/ticket/54179>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #54179: gv @3.7.4 fails to open correctly (was: gv 3.7.4 fails to open correctly)

MacPorts
#54179: gv @3.7.4 fails to open correctly
-----------------------+------------------------
  Reporter:  o12johns  |      Owner:  ryandesign
      Type:  defect    |     Status:  assigned
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:
Resolution:            |   Keywords:
      Port:  gv        |
-----------------------+------------------------
Changes (by ryandesign):

 * cc: o12johns (removed)
 * owner:   => ryandesign
 * status:  new => assigned


Old description:

> Up to date port installation.  E.g., xfig works correctly.  But gv does
> not.
>
> AeroNew:~ ojohns$ gv ~/Desktop/body-cone-earth.eps
>
> produces panel labeled
> GHOSTSCRIPT MESSAGES
> with the text:
>
> Unknown device: x11
>   ./base/gsicc_manage.c:1126: gsicc_open_search(): Could not find
> default_gray.icc
> | ./base/gsicc_manage.c:1754: gsicc_set_device_profile(): cannot find
> device profile
> Unrecoverable error: unknownerror in .special_op
> Operand stack:
>     defaultdevice
> Unrecoverable error: undefined in .uninstallpagedevice
> Operand stack:
>     defaultdevice
>
> Then gv program comes up, but with empty display.  Attempts to OPEN the
> eps file from
> within gv result in the same message as above.

New description:

 Up to date port installation.  E.g., xfig works correctly.  But gv does
 not.

 {{{
 AeroNew:~ ojohns$ gv ~/Desktop/body-cone-earth.eps
 }}}

 produces panel labeled
 {{{
 GHOSTSCRIPT MESSAGES
 }}}
 with the text:


 {{{
 Unknown device: x11
   ./base/gsicc_manage.c:1126: gsicc_open_search(): Could not find
 default_gray.icc
 | ./base/gsicc_manage.c:1754: gsicc_set_device_profile(): cannot find
 device profile
 Unrecoverable error: unknownerror in .special_op
 Operand stack:
     defaultdevice
 Unrecoverable error: undefined in .uninstallpagedevice
 Operand stack:
     defaultdevice
 }}}

 Then gv program comes up, but with empty display.  Attempts to OPEN the
 eps file from
 within gv result in the same message as above.

--

Comment:

 I can't exactly reproduce that on my system. If ghostscript is installed
 with the x11 variant, gs opens eps files just fine for me. If ghostscript
 is installed without the x11 variant, then gs displays just a watch cursor
 when trying to open eps files.

 So I would suggest if ghostscript is installed without the x11 variant,
 try reinstalling it with the x11 variant.

 {{{
 sudo port upgrade --enforce-variants ghostscript +x11
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/54179#comment:1>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #54179: gv @3.7.4 fails to open correctly

MacPorts
In reply to this post by MacPorts
#54179: gv @3.7.4 fails to open correctly
-----------------------+------------------------
  Reporter:  o12johns  |      Owner:  ryandesign
      Type:  defect    |     Status:  assigned
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:
Resolution:            |   Keywords:
      Port:  gv        |
-----------------------+------------------------

Comment (by o12johns):

 Problem is with gv not gs.  gs opens correctly.  gv does not.
 I did "sudo port upgrade --enforce-variants ghostscript +x11" as
 suggested.  Had no effect.
 My system is OSX, XQuartz, XCode all at their latest versions.
 When I cd to ~/ and then type just "gv", gv opens with empty panel.
 I then use the FILE : OPEN dialog to open "active-passive.eps".  I get the
 above GHOSTSCRIPT MESSAGES, as noted.
 But, I see that the heading of the gv window now reads "gv: active-
 passive.dvi".
 There is no file active-passive.dvi in my home directory.

--
Ticket URL: <https://trac.macports.org/ticket/54179#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #54179: gv @3.7.4 fails to open correctly

MacPorts
In reply to this post by MacPorts
#54179: gv @3.7.4 fails to open correctly
-----------------------+------------------------
  Reporter:  o12johns  |      Owner:  ryandesign
      Type:  defect    |     Status:  closed
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:
Resolution:  invalid   |   Keywords:
      Port:  gv        |
-----------------------+------------------------
Changes (by ryandesign):

 * status:  assigned => closed
 * resolution:   => invalid


Comment:

 User reported by email:

 > Solved.  Was a PATH problem.  I had an old version of gs hiding in my
 /usr/local/bin .  Please close the ticket.  Thanks for your patience.

--
Ticket URL: <https://trac.macports.org/ticket/54179#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS
Loading...