[MacPorts] #54121: Error: No files have been installed in the destroot directory!

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[MacPorts] #54121: Error: No files have been installed in the destroot directory!

MacPorts
#54121: Error: No files have been installed in the destroot directory!
----------------------+-----------------------------
 Reporter:  whodafly  |      Owner:
     Type:  defect    |     Status:  new
 Priority:  Normal    |  Milestone:
Component:  ports     |    Version:  2.4.1
 Keywords:            |       Port:  qt5-qtwebengine
----------------------+-----------------------------
 Mac OS X 10.9
 Xcode 6.1.1

 {{{
 @:~$ sudo port clean --all qt5-qtwebengine
 Password:
 --->  Cleaning qt5-qtwebengine
 @:~$ sudo port upgrade outdated
 Password:
 --->  Computing dependencies for qt5-qtwebengine
 --->  Fetching archive for qt5-qtwebengine
 --->  Attempting to fetch qt5-qtwebengine-5.7.1_0.darwin_13.x86_64.tbz2
 from https://packages.macports.org/qt5-qtwebengine
 --->  Attempting to fetch qt5-qtwebengine-5.7.1_0.darwin_13.x86_64.tbz2
 from http://sea.us.packages.macports.org/macports/packages/qt5-qtwebengine
 --->  Attempting to fetch qt5-qtwebengine-5.7.1_0.darwin_13.x86_64.tbz2
 from
 http://mse.uk.packages.macports.org/sites/packages.macports.org/qt5-qtwebengine
 --->  Fetching distfiles for qt5-qtwebengine
 --->  Attempting to fetch qtwebengine-opensource-src-5.7.1.tar.xz from
 https://distfiles.macports.org/qt5
 --->  Verifying checksums for qt5-qtwebengine
 --->  Extracting qt5-qtwebengine
 --->  Configuring qt5-qtwebengine
 --->  Building qt5-qtwebengine
 --->  Staging qt5-qtwebengine into destroot
 Error: No files have been installed in the destroot directory!
 Error: Please make sure that this software supports 'make install
 DESTDIR=${destroot}' or implement an alternative destroot mechanism in the
 Portfile.
 Error: Files might have been installed directly into your system, check
 before proceeding.
 Error: Failed to destroot qt5-qtwebengine: Staging qt5-qtwebengine into
 destroot failed
 Error: See
 /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt5/qt5-qtwebengine/main.log
 for details.
 Error: Follow https://guide.macports.org/#project.tickets to report a bug.
 @:~$
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/54121>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #54121: Error: No files have been installed in the destroot directory!

MacPorts
#54121: Error: No files have been installed in the destroot directory!
------------------------------+-------------------
  Reporter:  whodafly         |      Owner:
      Type:  defect           |     Status:  new
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:  2.4.1
Resolution:                   |   Keywords:
      Port:  qt5-qtwebengine  |
------------------------------+-------------------
Changes (by whodafly):

 * Attachment "main.log" added.

 main.log

--
Ticket URL: <https://trac.macports.org/ticket/54121>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #54121: qt5-qtwebengine @5.7.1: Error: No files have been installed in the destroot directory! (was: Error: No files have been installed in the destroot directory!)

MacPorts
In reply to this post by MacPorts
#54121: qt5-qtwebengine @5.7.1: Error: No files have been installed in the destroot
directory!
------------------------------+---------------------------------
  Reporter:  whodafly         |      Owner:  MarcusCalhoun-Lopez
      Type:  defect           |     Status:  assigned
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:  2.4.1
Resolution:                   |   Keywords:
      Port:  qt5-qtwebengine  |
------------------------------+---------------------------------
Changes (by ryandesign):

 * status:  new => assigned
 * owner:   => MarcusCalhoun-Lopez


--
Ticket URL: <https://trac.macports.org/ticket/54121#comment:1>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #54121: qt5-qtwebengine @5.7.1: Qt WebEngine requires an OS X SDK version of 10.10 or newer. (was: qt5-qtwebengine @5.7.1: Error: No files have been installed in the destroot directory!)

MacPorts
In reply to this post by MacPorts
#54121: qt5-qtwebengine @5.7.1: Qt WebEngine requires an OS X SDK version of 10.10
or newer.
------------------------------+---------------------------------
  Reporter:  whodafly         |      Owner:  MarcusCalhoun-Lopez
      Type:  defect           |     Status:  assigned
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:  2.4.1
Resolution:                   |   Keywords:
      Port:  qt5-qtwebengine  |
------------------------------+---------------------------------
Changes (by Ionic):

 * cc: Ionic (added)


Comment:

 The real problem here is that qtwebengine 5.7.1 is only compatible with
 10.10+. Can this easily be made compatible with 10.9+?

--
Ticket URL: <https://trac.macports.org/ticket/54121#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #54121: qt5-qtwebengine @5.7.1: Qt WebEngine requires an OS X SDK version of 10.10 or newer.

MacPorts
In reply to this post by MacPorts
#54121: qt5-qtwebengine @5.7.1: Qt WebEngine requires an OS X SDK version of 10.10
or newer.
------------------------------+---------------------------------
  Reporter:  whodafly         |      Owner:  MarcusCalhoun-Lopez
      Type:  defect           |     Status:  assigned
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:  2.4.1
Resolution:                   |   Keywords:
      Port:  qt5-qtwebengine  |
------------------------------+---------------------------------

Comment (by whodafly):

 I'd be happy to help - for various reasons I'd prefer to stay on 10.9 for
 the moment. If someone gives me a couple of pointers I'd be more than
 happy to poke around.

--
Ticket URL: <https://trac.macports.org/ticket/54121#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #54121: qt5-qtwebengine @5.7.1: Qt WebEngine requires an OS X SDK version of 10.10 or newer.

MacPorts
In reply to this post by MacPorts
#54121: qt5-qtwebengine @5.7.1: Qt WebEngine requires an OS X SDK version of 10.10
or newer.
------------------------------+---------------------------------
  Reporter:  whodafly         |      Owner:  MarcusCalhoun-Lopez
      Type:  defect           |     Status:  assigned
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:  2.4.1
Resolution:                   |   Keywords:
      Port:  qt5-qtwebengine  |
------------------------------+---------------------------------

Comment (by Ionic):

 Looks like the fix is easy - build against the 10.10 SDK on 10.9. Doesn't
 make a whole lot of sense, but I'll test it.

--
Ticket URL: <https://trac.macports.org/ticket/54121#comment:4>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #54121: qt5-qtwebengine @5.7.1: Qt WebEngine requires an OS X SDK version of 10.10 or newer.

MacPorts
In reply to this post by MacPorts
#54121: qt5-qtwebengine @5.7.1: Qt WebEngine requires an OS X SDK version of 10.10
or newer.
------------------------------+---------------------------------
  Reporter:  whodafly         |      Owner:  MarcusCalhoun-Lopez
      Type:  defect           |     Status:  closed
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:  2.4.1
Resolution:  fixed            |   Keywords:
      Port:  qt5-qtwebengine  |
------------------------------+---------------------------------
Changes (by Mihai Moldovan <ionic@…>):

 * status:  assigned => closed
 * resolution:   => fixed


Comment:

 In [changeset:"4a3250a8c2018ec963ba5f069c2d7623a520dff6/macports-ports"
 4a3250a8c2018ec963ba5f069c2d7623a520dff6/macports-ports]:
 {{{
 #!ConfigurableCommitTicketReference repository="macports-ports"
 revision="4a3250a8c2018ec963ba5f069c2d7623a520dff6"
 aqua/qt5: fix qt5-qtwebengine on OS X 10.9.

 Fixes: https://trac.macports.org/ticket/54121.
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/54121#comment:5>
MacPorts <https://www.macports.org/>
Ports system for macOS