[MacPorts] #53926: maxima build failure

classic Classic list List threaded Threaded
18 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[MacPorts] #53926: maxima build failure

MacPorts
#53926: maxima build failure
-----------------------------------+-----------------------------
 Reporter:  dyne2meter             |      Owner:
     Type:  defect                 |     Status:  new
 Priority:  Normal                 |  Milestone:
Component:  ports                  |    Version:
 Keywords:  mavericks, el capitan  |       Port:  maxima 5.39.0.2
-----------------------------------+-----------------------------
 Fails during "making all in doc" with "sh extract_categories.sh maxima"

 see lines 17975 - 17987 of attached log; above is invoked at line 17979 of
 my log

--
Ticket URL: <https://trac.macports.org/ticket/53926>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima build failure

MacPorts
#53926: maxima build failure
------------------------------+-----------------------------------
  Reporter:  dyne2meter       |      Owner:
      Type:  defect           |     Status:  new
  Priority:  Normal           |  Milestone:
 Component:  ports            |    Version:
Resolution:                   |   Keywords:  mavericks, el capitan
      Port:  maxima 5.39.0.2  |
------------------------------+-----------------------------------
Changes (by dyne2meter):

 * Attachment "main.log" added.

 main log file

--
Ticket URL: <https://trac.macports.org/ticket/53926>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure (was: maxima build failure)

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------
Changes (by ryandesign):

 * status:  new => assigned
 * cc: KubaO (removed)
 * keywords:  mavericks, el capitan =>
 * owner:   => KubaO
 * port:  maxima 5.39.0.2 => maxima


Comment:

 {{{
 :info:build ** Bad line in /usr/local/share/texinfo//htmlxref.cnf:
 htmlxrefversion=2013-08-03.16; # UTC
 }}}

 Remove what you have installed in /usr/local. See wiki:FAQ#usrlocal.

--
Ticket URL: <https://trac.macports.org/ticket/53926#comment:1>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------

Comment (by dyne2meter):

 I've had TeX installed in /usr/local for ages, the 2015 TeXlive, and it's
 only just started this interference, which I guess comes in with the
 update of maxima. Thanks for the heads up. I've been explicitly instructed
 by some build scripts for other software to take /opt/local out of my
 path, and this tactic might consequently have occurred to me; thanks for
 the quick pointer.

--
Ticket URL: <https://trac.macports.org/ticket/53926#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------

Comment (by dyne2meter):

 No, that was not the problem. I took /usr/local entirely out of my path
 and rebooted, and the maxima build fails at exactly the same point.

--
Ticket URL: <https://trac.macports.org/ticket/53926#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------

Comment (by mf2k):

 Please attach the new main.log file.

--
Ticket URL: <https://trac.macports.org/ticket/53926#comment:4>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------
Changes (by dyne2meter):

 * Attachment "main.2.log" added.


--
Ticket URL: <https://trac.macports.org/ticket/53926>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------

Comment (by dyne2meter):

 The new main.log file is now attached.

--
Ticket URL: <https://trac.macports.org/ticket/53926#comment:5>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------

Comment (by dyne2meter):

 Good news, sorta: I just successfully upgraded maxima as current
 (5.39.0.2). This is following installation of the octave upgrade which
 installs some stuff from texlive.bin, plus fonts and other stuff. In my
 installation of macports, a lot of this 'other stuff' is designated
 'leaves' after the installation is done, and I usually uninstall my
 leaves. I don't have any idea if it's related to the build fail that
 prompted this ticket..

 That said, I've got problems with broken ports of ImageMagick and
 ghostscript that I have to run ''port rev-upgrade'' on. That's just
 informational, and I will post a new ticket based on the output I get if
 somebody else hasn't, already.

--
Ticket URL: <https://trac.macports.org/ticket/53926#comment:7>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------
Changes (by dyne2meter):

 * Attachment "main.3.log" added.

 main log file, 5.39.0.3

--
Ticket URL: <https://trac.macports.org/ticket/53926>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------

Comment (by dyne2meter):

 No joy in Mudville, again.

--
Ticket URL: <https://trac.macports.org/ticket/53926#comment:8>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------

Comment (by dyne2meter):

 Once again, the new octave update comes to the rescue, and with its build
 dependencies installed, the maxima build succeeds. This is not too tedious
 a process on the dual quad-core MacPro @3.0 GHz, but it takes about an
 hour to install octave on the dual core iMac running @ 2.4 GHz. It would
 be nice to know which (few?) of these build dependencies are essential in
 my case. It could be that my installations of MacPorts have some
 idiosyncracies as a  result of manually updating the rest of my installed
 ports when one port is not building. I just don't know the ins and outs,
 and I don't know how large is the maxima user base that is ''not'' having
 this problem. It's an interesting situation, at least for me.

--
Ticket URL: <https://trac.macports.org/ticket/53926#comment:10>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------
Changes (by dyne2meter):

 * Attachment "main.log.gz" added.

 main log

--
Ticket URL: <https://trac.macports.org/ticket/53926>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------

Comment (by dyne2meter):

 Another maxima update build failure. Log enclosed.

--
Ticket URL: <https://trac.macports.org/ticket/53926#comment:11>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------
Changes (by friendbthomas):

 * Attachment "main.4.log.gz" added.

 Build failure in generating manual

--
Ticket URL: <https://trac.macports.org/ticket/53926>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------

Comment (by friendbthomas):

 A build failure still exits, and it happens when building the texinfo
 manual. The log file (main.4.log.gz) is attached. This happens after even
 self update and cleaning.

--
Ticket URL: <https://trac.macports.org/ticket/53926#comment:12>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------

Comment (by dyne2meter):

 The required TeX-related package(s) are installed as build dependencies
 during the building of octave, but I don't know exactly which ones are
 required for maxima.

--
Ticket URL: <https://trac.macports.org/ticket/53926#comment:13>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53926: maxima @5.39.0_2: build failure

MacPorts
In reply to this post by MacPorts
#53926: maxima @5.39.0_2: build failure
-------------------------+----------------------
  Reporter:  dyne2meter  |      Owner:  KubaO
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:
Resolution:              |   Keywords:
      Port:  maxima      |
-------------------------+----------------------

Comment (by friendbthomas):

 '''Workaround''' : The build and install does succeed if the full variant
 of texlive is installed. This may be a useful workaround for others facing
 this problem.

--
Ticket URL: <https://trac.macports.org/ticket/53926#comment:14>
MacPorts <https://www.macports.org/>
Ports system for macOS
Loading...