Quantcast

[MacPorts] #53818: fox: version upgrade breaks sumo

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[MacPorts] #53818: fox: version upgrade breaks sumo

MacPorts
#53818: fox: version upgrade breaks sumo
----------------------+-----------------
 Reporter:  lockhart  |      Owner:
     Type:  defect    |     Status:  new
 Priority:  Normal    |  Milestone:
Component:  ports     |    Version:
 Keywords:            |       Port:  fox
----------------------+-----------------
 The fox upgrade to 1.6.53 breaks the sumo port, giving a segfault on
 program start for programs having a GUI (e.g. sumo-gui and netedit).
 The previous version of fox, 1.6.46, exhibited not such problems.
 Are there any ports known to work with fox-1.6.53?
 I would recommend reverting the fox version to 1.6.46.
 I am the maintainer for the sumo port and have no indication that
 fox-1.6.53 can be made to work.

--
Ticket URL: <https://trac.macports.org/ticket/53818>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53818: fox: version upgrade breaks sumo

MacPorts
#53818: fox: version upgrade breaks sumo
-----------------------+-----------------
  Reporter:  lockhart  |      Owner:
      Type:  defect    |     Status:  new
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:
Resolution:            |   Keywords:
      Port:  fox       |
-----------------------+-----------------

Comment (by ryandesign):

 Can you cite any upstream bug reports -- confirmation from either sumo or
 fox developers about this problem?

--
Ticket URL: <https://trac.macports.org/ticket/53818#comment:1>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53818: fox: version upgrade breaks sumo

MacPorts
In reply to this post by MacPorts
#53818: fox: version upgrade breaks sumo
-----------------------+-----------------
  Reporter:  lockhart  |      Owner:
      Type:  defect    |     Status:  new
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:
Resolution:            |   Keywords:
      Port:  fox       |
-----------------------+-----------------

Comment (by lockhart):

 Replying to [comment:1 ryandesign]:
 > Can you cite any upstream bug reports -- confirmation from either sumo
 or fox developers about this problem?
 There has been discussion on the SUMO user's mailing list regarding the
 problem. The solution came from someone familiar with Homebrew and the
 fact that Homebrew has revlocked Fox to a much earlier version.
 I can poll SUMO developers to see what version they use, but that does not
 change the fact that the version of Fox coming in a recent update to
 MacPorts breaks SUMO tools on MacPorts. The previous version of Fox in
 MacPorts is known to work.

--
Ticket URL: <https://trac.macports.org/ticket/53818#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS
Loading...