Quantcast

[MacPorts] #53799: nodejs7 @7.7.2 Build failure

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[MacPorts] #53799: nodejs7 @7.7.2 Build failure

MacPorts
#53799: nodejs7 @7.7.2 Build failure
--------------------+---------------------
 Reporter:  ghlecl  |      Owner:
     Type:  defect  |     Status:  new
 Priority:  Normal  |  Milestone:
Component:  ports   |    Version:  2.4.1
 Keywords:          |       Port:  nodejs7
--------------------+---------------------
 Tried to update NodeJS by building it.  Fails everytime.

 Even after clean, clean --dist and clean --all or various combinations of
 those.  I have also uninstalled the port and tried to reinstall it.  Did
 not work.

 There seems to be a problem at the "applying patches" step of the process
 where the build script seems to warn that the reinplace command does
 nothing.  I have joined a screen shot of the messages to this report.
 Here is an example of the warning:
 {{{
 Warning: reinplace s|/usr/bin/env python|/opt/local/bin/python2.7| didn't
 change anything in
 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs7/nodejs7/work/node-v7.7.2/tools/gyp/gyp
 Warning: reinplace s|/usr/bin/env python|/opt/local/bin/python2.7| didn't
 change anything in
 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs7/nodejs7/work/node-v7.7.2/deps/npm/node_modules
 /node-gyp/gyp/PRESUBMIT.py
 }}}
 Might not be related, but thought I would mention it.

 I am also joining the build log that has the failure report in it.  This
 is not the build log of my last attempt as the last attempt was stopped by
 SIGKILL and never finished.  I had to actually use Ctrl-C after a while
 even if it said it received SIGKILL, which was wierd to me.

--
Ticket URL: <https://trac.macports.org/ticket/53799>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53799: nodejs7 @7.7.2 Build failure

MacPorts
#53799: nodejs7 @7.7.2 Build failure
----------------------+-------------------
  Reporter:  ghlecl   |      Owner:
      Type:  defect   |     Status:  new
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.4.1
Resolution:           |   Keywords:
      Port:  nodejs7  |
----------------------+-------------------
Changes (by ghlecl):

 * Attachment "main.log" added.

 main log

--
Ticket URL: <https://trac.macports.org/ticket/53799>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53799: nodejs7 @7.7.2 Build failure

MacPorts
In reply to this post by MacPorts
#53799: nodejs7 @7.7.2 Build failure
----------------------+-------------------
  Reporter:  ghlecl   |      Owner:
      Type:  defect   |     Status:  new
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.4.1
Resolution:           |   Keywords:
      Port:  nodejs7  |
----------------------+-------------------
Changes (by ghlecl):

 * Attachment "SIGKILL.png" added.

 screen_shot_1_sigkill

--
Ticket URL: <https://trac.macports.org/ticket/53799>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53799: nodejs7 @7.7.2 Build failure

MacPorts
In reply to this post by MacPorts
#53799: nodejs7 @7.7.2 Build failure
----------------------+-------------------
  Reporter:  ghlecl   |      Owner:
      Type:  defect   |     Status:  new
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.4.1
Resolution:           |   Keywords:
      Port:  nodejs7  |
----------------------+-------------------
Changes (by ghlecl):

 * Attachment "Reinplace.png" added.

 reinplace_error

--
Ticket URL: <https://trac.macports.org/ticket/53799>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53799: nodejs7 @7.7.2 Build failure

MacPorts
In reply to this post by MacPorts
#53799: nodejs7 @7.7.2 Build failure
----------------------+----------------------
  Reporter:  ghlecl   |      Owner:  ci42
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.4.1
Resolution:           |   Keywords:
      Port:  nodejs7  |
----------------------+----------------------
Changes (by ci42):

 * status:  new => assigned
 * owner:   => ci42
 * cc: ciserlohn@… (removed)


--
Ticket URL: <https://trac.macports.org/ticket/53799#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53799: nodejs7 @7.7.2 Build failure

MacPorts
In reply to this post by MacPorts
#53799: nodejs7 @7.7.2 Build failure
----------------------+----------------------
  Reporter:  ghlecl   |      Owner:  ci42
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.4.1
Resolution:           |   Keywords:
      Port:  nodejs7  |
----------------------+----------------------

Comment (by ci42):

 Replying to [ticket:53799 ghlecl]:

 > There seems to be a problem at the "applying patches" step of the
 process where the build script seems to warn that the reinplace command
 does nothing.  I have joined a screen shot of the messages to this report.
 Here is an example of the warning:
 > {{{
 > Warning: reinplace s|/usr/bin/env python|/opt/local/bin/python2.7|
 didn't change anything in
 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs7/nodejs7/work/node-v7.7.2/tools/gyp/gyp
 > Warning: reinplace s|/usr/bin/env python|/opt/local/bin/python2.7|
 didn't change anything in
 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs7/nodejs7/work/node-v7.7.2/deps/npm/node_modules
 /node-gyp/gyp/PRESUBMIT.py
 > }}}
 > Might not be related, but thought I would mention it.

 No, they are not related.

 I think this is the problem:

 {{{
 :info:build darwintrace: socket: Too many open files in system
 :info:build /bin/sh: /usr/bin/grep: Too many open files in system
 }}}

 Could you please try again without trace mode enabled?

--
Ticket URL: <https://trac.macports.org/ticket/53799#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53799: nodejs7 @7.7.2 Build failure

MacPorts
In reply to this post by MacPorts
#53799: nodejs7 @7.7.2 Build failure
----------------------+----------------------
  Reporter:  ghlecl   |      Owner:  ci42
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.4.1
Resolution:           |   Keywords:
      Port:  nodejs7  |
----------------------+----------------------
Changes (by mf2k):

 * cc: ghlecl (removed)


Comment:

 As reporter, you do not need to Cc yourself.

--
Ticket URL: <https://trac.macports.org/ticket/53799#comment:4>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53799: nodejs7 @7.7.2 Build failure

MacPorts
In reply to this post by MacPorts
#53799: nodejs7 @7.7.2 Build failure
----------------------+----------------------
  Reporter:  ghlecl   |      Owner:  ci42
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.4.1
Resolution:           |   Keywords:
      Port:  nodejs7  |
----------------------+----------------------

Comment (by ghlecl):

 Hi.

 @mf2k Thanks.  Wasn't sure and did not want to miss comments and seem
 unresponsive.

 @ci42 I just did try to reinstall without trace mode enabled and it did
 work.  Thanks for letting me know it can be a problem.  I did not think it
 could hurt so I just enabled it by default all the time.  My mistake. I'll
 have to read up on what it does in a little more details.

 Should I be the one to mark as resolved or something ?  I guess not, but
 just don't want to cause any problem.

 Thanks again.

--
Ticket URL: <https://trac.macports.org/ticket/53799#comment:5>
MacPorts <https://www.macports.org/>
Ports system for macOS
Loading...