[MacPorts] #53584: mpv@leopard(ppc) - failed to activate ghostscript

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[MacPorts] #53584: mpv@leopard(ppc) - failed to activate ghostscript

MacPorts
#53584: mpv@leopard(ppc) - failed to activate ghostscript
-------------------------------------+-------------------
 Reporter:  mrkapqa                  |      Owner:
     Type:  defect                   |     Status:  new
 Priority:  Normal                   |  Milestone:
Component:  ports                    |    Version:  2.4.0
 Keywords:  mpv leopard ghostscript  |       Port:
-------------------------------------+-------------------
 {{{
 ttempting to fetch 0bdcfbe5e394d4519e5969918c34d4eebf76a386.zip from
 http://lil.fr.distfiles.macports.org/ghostscript
 --->  Verifying checksums for ghostscript
 --->  Extracting ghostscript
 --->  Applying patches to ghostscript
 --->  Configuring ghostscript
 --->  Building ghostscript
 --->  Staging ghostscript into destroot
 --->  Installing ghostscript @9.19_0+x11
 --->  Activating ghostscript @9.19_0+x11
 Error: Failed to activate ghostscript: command execution failed
 }}}

 on imac g5 running leopard 10.5.8 with xcode 3.1.4 using

 "sudo port install mpv
 +audiocd+bundle+dvd+libarchive+network+opengl+osdÃ¥+python27-rubberband+x11"

--
Ticket URL: <https://trac.macports.org/ticket/53584>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53584: mpv@leopard(ppc) - failed to activate ghostscript

MacPorts
#53584: mpv@leopard(ppc) - failed to activate ghostscript
----------------------+-------------------------------------
  Reporter:  mrkapqa  |      Owner:
      Type:  defect   |     Status:  new
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.4.0
Resolution:           |   Keywords:  mpv leopard ghostscript
      Port:           |
----------------------+-------------------------------------
Changes (by mrkapqa):

 * Attachment "g5" added.


--
Ticket URL: <https://trac.macports.org/ticket/53584>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53584: failed to activate ghostscript (was: mpv@leopard(ppc) - failed to activate ghostscript)

MacPorts
In reply to this post by MacPorts
#53584: failed to activate ghostscript
--------------------------+-------------------
  Reporter:  mrkapqa      |      Owner:
      Type:  defect       |     Status:  new
  Priority:  Normal       |  Milestone:
 Component:  ports        |    Version:  2.4.0
Resolution:               |   Keywords:
      Port:  ghostscript  |
--------------------------+-------------------
Changes (by mf2k):

 * keywords:  mpv leopard ghostscript =>
 * port:   => ghostscript


Comment:

 In the future, please fill in the Port field with the port that actually
 fails to build and Cc that port's maintainers ({{{port info --maintainers
 ghostscript}}}), if any.

--
Ticket URL: <https://trac.macports.org/ticket/53584#comment:1>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53584: failed to activate ghostscript

MacPorts
In reply to this post by MacPorts
#53584: failed to activate ghostscript
--------------------------+-------------------
  Reporter:  mrkapqa      |      Owner:
      Type:  defect       |     Status:  new
  Priority:  Normal       |  Milestone:
 Component:  ports        |    Version:  2.4.0
Resolution:               |   Keywords:
      Port:  ghostscript  |
--------------------------+-------------------

Comment (by mf2k):

 From the log, it stopped here:
 {{{
 :debug:activate system: /opt/local/bin/fc-cache -v
 /opt/local/share/fonts/Type1/gsfonts
 :info:activate Command failed: /opt/local/bin/fc-cache -v
 /opt/local/share/fonts/Type1/gsfonts
 :info:activate Killed by signal: 10
 }}}

 It was rebuilding the font cache which takes some time. Did you hit
 Control-C? How long did you wait before doing so?

--
Ticket URL: <https://trac.macports.org/ticket/53584#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [MacPorts] #53584: failed to activate ghostscript

MacPorts
In reply to this post by MacPorts
#53584: failed to activate ghostscript
--------------------------+-------------------
  Reporter:  mrkapqa      |      Owner:
      Type:  defect       |     Status:  new
  Priority:  Normal       |  Milestone:
 Component:  ports        |    Version:  2.4.0
Resolution:               |   Keywords:
      Port:  ghostscript  |
--------------------------+-------------------

Comment (by victorp-sg):

 {{{
 :debug:activate activating file: /opt/local/share/man/man1/ps2pdf.1.gz
 :debug:activate activating file: /opt/local/share/man/man1/ps2pdf12.1.gz
 :debug:activate activating file: /opt/local/share/man/man1/ps2pdf13.1.gz
 :debug:activate activating file: /opt/local/share/man/man1/ps2pdf14.1.gz
 :debug:activate activating file: /opt/local/share/man/man1/ps2pdfwr.1.gz
 :debug:activate activating file: /opt/local/share/man/man1/ps2ps.1.gz
 :debug:activate activating file: /opt/local/share/man/man1/wftopfa.1.gz
 :debug:activate Executing proc-post-org.macports.activate-activate-0
 :debug:activate system: /opt/local/bin/fc-cache -v
 /opt/local/share/fonts/Type1/gsfonts
 :info:activate Command failed: /opt/local/bin/fc-cache -v
 /opt/local/share/fonts/Type1/gsfonts
 :info:activate Killed by signal: 10
 :error:activate Failed to activate ghostscript: command execution failed
 :debug:activate Error code: NONE
 :debug:activate Backtrace: command execution failed
 :debug:activate     while executing
 :debug:activate "$post $targetname"
 :debug:activate could not read "/opt/local/share/man/man1/wftopfa.1.gz":
 no such file or directory
 :debug:activate     while executing
 :debug:activate "::file type $file"
 :error:activate See
 /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_print_ghostscript/ghostscript/main.log
 for details.
 }}}
 I have the exact same problem on a Power Mac G5 running Mac OS X 10.5.8
 and the excerpt from the relevant section of the log file is shown above
 with, what looks like, the reason of the failure. Can it be related to the
 issue in Ticket #53669 where I have this same warning while installing?
 {{{
 --->  Applying patches to ghostscript
 Warning: reinplace s|#!/usr/bin/perl|#!/opt/local/bin/perl| didn't change
 anything in
 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_print_ghostscript/ghostscript/work/ghostscript-9.19/freetype_local/src/tools/afblue.pl
 --->  Configuring ghostscript
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/53584#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS
Loading...