[MacPorts] #52632: Inkscape-app quits immediately after install

classic Classic list List threaded Threaded
34 messages Options
12
Reply | Threaded
Open this post in threaded view
|

[MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
#52632: Inkscape-app quits immediately after install
-----------------------------------+--------------------------------
 Reporter:  iansidor@…             |      Owner:  macports-tickets@…
     Type:  defect                 |     Status:  new
 Priority:  Normal                 |  Milestone:
Component:  ports                  |    Version:  2.3.4
 Keywords:  inkscape inkscape-app  |       Port:  inkscape-app
-----------------------------------+--------------------------------
 I've just installed Inkscape by using the following command:


 {{{
 sudo port install inkscape-app
 }}}


 I found Inkscape in '''/Applications/MacPorts''' and tried to double click
 the icon to boot up the application. It seems to shift the doc slightly as
 if it's making room for the icon but then it collapses almost immediately
 and the application never boots.

--
Ticket URL: <https://trac.macports.org/ticket/52632>
MacPorts <https://www.macports.org/>
Ports system for the Mac operating system
_______________________________________________
macports-tickets mailing list
[hidden email]
https://lists.macosforge.org/mailman/listinfo/macports-tickets
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------
Changes (by mf2k@…):

 * cc: devans@… (added)
 * keywords:  inkscape inkscape-app =>


--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:1>
MacPorts <https://www.macports.org/>
Ports system for the Mac operating system
_______________________________________________
macports-tickets mailing list
[hidden email]
https://lists.macosforge.org/mailman/listinfo/macports-tickets
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by ryandesign@…):

 That sounds like a crash happened. Is there a crash log for this event?
 macOS would have saved it in ~/Library/Logs/DiagnosticReports. If there is
 one for this crash (check that inkscape is in the filename and that the
 date/time matches), please attach it to this ticket.

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:2>
MacPorts <https://www.macports.org/>
Ports system for the Mac operating system
_______________________________________________
macports-tickets mailing list
[hidden email]
https://lists.macosforge.org/mailman/listinfo/macports-tickets
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by devans@…):

 Also please let us know which version of inkscape you have installed and
 active -- +x11 or +quartz or even +gtk3, I guess.  What's the result of
 this command?
 {{{
 port installed inkscape
 }}}


 In any case, the work-around for this problem would be to invoke inkscape
 from the command line in a terminal.


 {{{
 $ inkscape
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:3>
MacPorts <https://www.macports.org/>
Ports system for the Mac operating system
_______________________________________________
macports-tickets mailing list
[hidden email]
https://lists.macosforge.org/mailman/listinfo/macports-tickets
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by iansidor@…):

 Replying to [comment:2 ryandesign@…]:
 > That sounds like a crash happened. Is there a crash log for this event?
 macOS would have saved it in ~/Library/Logs/DiagnosticReports. If there is
 one for this crash (check that inkscape is in the filename and that the
 date/time matches), please attach it to this ticket.

 I initially thought it was a crash but I would have expected a Mac OS X
 default crash prompt to be displayed. Do you think it could be a
 permissions issue?

 Unfortunately nothing appears in ~/Library/Logs/DiagnosticReports.

 NB: I'm running OS X 10.12 Sierra

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:4>
MacPorts <https://www.macports.org/>
Ports system for the Mac operating system
_______________________________________________
macports-tickets mailing list
[hidden email]
https://lists.macosforge.org/mailman/listinfo/macports-tickets
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by iansidor@…):

 Replying to [comment:3 devans@…]:
 > Also please let us know which version of inkscape you have installed and
 active -- +x11 or +quartz or even +gtk3, I guess.  What's the result of
 this command?
 > {{{
 > port installed inkscape
 > }}}
 >
 >
 > In any case, the work-around for this problem would be to invoke
 inkscape from the command line in a terminal.
 >
 >
 > {{{
 > $ inkscape
 > }}}


 {{{
 $ port installed inkscape
 The following ports are currently installed:
 inkscape @0.91_17+x11 (active)
 }}}

 I've tried your workaround suggestion but that doesn't seem to work.

 {{{
 $ inkscape
 Nothing to do!
 }}}

 I appreciate the help.

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:5>
MacPorts <https://www.macports.org/>
Ports system for the Mac operating system
_______________________________________________
macports-tickets mailing list
[hidden email]
https://lists.macosforge.org/mailman/listinfo/macports-tickets
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by devans@…):

 Yes, but now we can see that your problem is probably not with inkscape-
 app but with launching inkscape, itself.

 Just to be complete, which X11 server are you using? XQuartz or one of the
 MacPorts versions (xorg-server, xorg-server-devel)? Does it launch when
 you invoke inkscape directly?
 Do other X11 programs seem to work OK?

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:6>
MacPorts <https://www.macports.org/>
Ports system for the Mac operating system
_______________________________________________
macports-tickets mailing list
[hidden email]
https://lists.macosforge.org/mailman/listinfo/macports-tickets
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------
Changes (by hugo-ribeiro):

 * Attachment "inkscape_2016-11-07.crash" added.


--
Ticket URL: <https://trac.macports.org/ticket/52632>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by hugo-ribeiro):

 I've just run into a similar problem after upgrading to Sierra. I'm also
 using inkscape instead of inkscape-app.

 I've installed X11 server from Macports (xorg-server) and it seems to work
 fine since I can launch gimp2 for example.
 I've also tried to install "enchant +aspell" instead of "enchant
 +applespell" (see ticket 51287: [https://trac.macports.org/ticket/51287]).

 I've attached a crash log. Hope this helps to find out what the problem
 is.

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:7>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by ichbindannmalwegmann):

 Any news? On my machine inkscape generates a segmentation fault too with
 the same already reported stack trace.

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:9>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by bgrube):

 I can also confirm the reported problem. The crash occurs with a clean
 MacPorts installation for the inkscape variants +x11, +quartz, and
 +gtk3+quartz. Same also for inkscape-devel +x11 (I did not try the other
 variants). I'm using Sierra and XQuartz 2.7.11 (xorg-server 1.18.4).

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:10>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by hugo-ribeiro):

 This got weird. I wanted to see if I could pinpoint where the problem was
 by using Instruments (mac OS "profiler"). It turned out that Inkscape
 starts and is perfectly usable if launched within Instruments. However, it
 still crashes if launched from the console. Hope this bit of information
 helps.

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:11>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by hugo-ribeiro):

 Ok. I found where the problem was coming from in my case. In my
 .bash_profile I had the following lines

 {{{
 export LC_ALL=en_US.UTF-8
 export LANG=en_US.UTF-8
 }}}

 to define a clean UTF-8 environment. By commenting these two lines, I'm
 able to start Inkscape. Annoyingly, this was never a problem with Mac OS
 X. The problem only appeared with Sierra.

 If someone knows how to define a clean UTF-8 environment and have inkscape
 start, please let me know.

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:12>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by bgrube):

 Same here. My shell environment had LANG=en_US.UTF-8 set and inkscape was
 crashing at start as reported above. Using
 {{{
 export LANG=en_US
 export LC_ALL=$LANG
 }}}
 I can start inkscape from the command line.

 Similar problems appear, when more than one language is selected in
 Sierra's "Language & Region" settings. I had German in addition to U.S.
 English, where the latter was the "Primary" language. Starting Inkscape
 from the Application folder, it crashes as reported above and shows the
 "internal error" dialog box in German. After removing the secondary
 language, Inkscape starts without problems.

 So in addition to the problem with UTF-8 locale, it seems that inkscape-
 app does not correctly pick up the language from the system settings. It
 should favor the "Primary" language.

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:13>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by atuyosi):

 I also got to have a similar problem with Inkscape-devel package.


 - $ LANG=ja_JP.UTF-8 inkscape -> NG display a message such like "Internal
 error occurred" in Japanese, and exit.
 - $ LANG=ja_JP inkscape            -> OK
 - $ LANG=C inkscape            -> OK

 I hope this information is useful for something.

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:14>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------
Changes (by raimue):

 * Attachment "0001-inkscape-Fix-crash-on-font-name-style-being-NULL.patch"
 added.


--
Ticket URL: <https://trac.macports.org/ticket/52632>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by raimue):

 Here is a patch that solves the problem for me. It is partly based on a
 backport from upstream trunk, but still required an additional null-check.
 Increasing revision as this fixes a runtime problem.

 I did not look too closely, therefore I did not identify which font(s) are
 actually causing this problem.

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:15>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by ichbindannmalwegmann):

 With environment variable "LANG" set to "de_CH.UTF-8" and "LC_CTYPE" unset
 Inkscape crashes but with "LC_CTYPE" set to "UTF-8" additionally it works.
 I discovered this by enabling the setting "Set locale environment
 variables on startup" in the tab "Advanced" in the "Peferences..." menu
 item of the "Terminal" application.

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:16>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
---------------------------+--------------------------------
  Reporter:  iansidor@…    |      Owner:  macports-tickets@…
      Type:  defect        |     Status:  new
  Priority:  Normal        |  Milestone:
 Component:  ports         |    Version:  2.3.4
Resolution:                |   Keywords:
      Port:  inkscape-app  |
---------------------------+--------------------------------

Comment (by paxperscientiam):

 Replying to [comment:13 bgrube]:
 > Same here. My shell environment had LANG=en_US.UTF-8 set and inkscape
 was crashing at start as reported above. Using
 > {{{
 > export LANG=en_US
 > export LC_ALL=$LANG
 > }}}
 > I can start inkscape from the command line.
 >
 > Similar problems appear, when more than one language is selected in
 Sierra's "Language & Region" settings. I had German in addition to U.S.
 English, where the latter was the "Primary" language. Starting Inkscape
 from the Application folder, it crashes as reported above and shows the
 "internal error" dialog box in German. After removing the secondary
 language, Inkscape starts without problems.
 >
 > So in addition to the problem with UTF-8 locale, it seems that inkscape-
 app does not correctly pick up the language from the system settings. It
 should favor the "Primary" language.


 I can confirm that setting `export LANG=en_US` and `export LC_ALL=$LANG`
 makes inkscape less crashy for me; however, it's not a viable solution for
 me (and surely others) as I need UTF8.

--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:18>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #52632: Inkscape-app quits immediately after install

MacPorts
In reply to this post by MacPorts
#52632: Inkscape-app quits immediately after install
------------------------------------+----------------------
  Reporter:  iansidor@…             |      Owner:  dbevans
      Type:  defect                 |     Status:  assigned
  Priority:  Normal                 |  Milestone:
 Component:  ports                  |    Version:  2.3.4
Resolution:                         |   Keywords:
      Port:  inkscape inkscape-app  |
------------------------------------+----------------------
Changes (by jmroot):

 * cc: dbevans (removed)
 * status:  new => assigned
 * port:  inkscape-app => inkscape inkscape-app
 * owner:  macports-tickets@… => dbevans


--
Ticket URL: <https://trac.macports.org/ticket/52632#comment:20>
MacPorts <https://www.macports.org/>
Ports system for macOS
12