[MacPorts] #49395: openmotif: internal error: hellomotif fails to link

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[MacPorts] #49395: openmotif: internal error: hellomotif fails to link

MacPorts
#49395: openmotif: internal error: hellomotif fails to link
---------------------+--------------------------------
 Reporter:  jries@…  |      Owner:  macports-tickets@…
     Type:  defect   |     Status:  new
 Priority:  Normal   |  Milestone:
Component:  ports    |    Version:  2.3.4
 Keywords:           |       Port:
---------------------+--------------------------------
 When doing a routine update (port upgrade outdated following port
 selfupdate), the compilation of openmotif fails as follows:

 Error: org.macports.build for port openmotif returned: command execution
 failed
 Please see the log file for port openmotif for details:
 /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_openmotif/openmotif/main.log
 Error: Unable to upgrade port: 1
 To report a bug, follow the instructions in the guide:
     http://guide.macports.org/#project.tickets

 A look at the log indicates that build fails on the linking of hellomotif
 (starting at main.log:4538):

 :info:build /bin/sh ../../../libtool  --tag=CC   --mode=link
 /usr/bin/clang  -pipe -Os -arch x86_64 -Wall -g -fno-strict-aliasing -Wno-
 unused -Wno-comment -I/opt/local/include -I/opt/local/include/freetype2
 -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include
 -I/opt/local/include/libpng16 -I/opt/local/include     -L/opt/local/lib
 -Wl,-headerpad_max_install_names -arch x86_64 -o hellomotif hellomotif.o
 ../../../lib/Xm/libXm.la ../../../lib/Mrm/libMrm.la -lXp -liconv
 -L/opt/local/lib -lXft -lXrender -L/opt/local/lib -lXft  -ljpeg -lpng
 :info:build libtool: link: /usr/bin/clang -pipe -Os -arch x86_64 -Wall -g
 -fno-strict-aliasing -Wno-unused -Wno-comment -I/opt/local/include
 -I/opt/local/include/freetype2 -I/opt/local/include
 -I/opt/local/include/freetype2 -I/opt/local/include
 -I/opt/local/include/libpng16 -I/opt/local/include
 -Wl,-headerpad_max_install_names -arch x86_64 -o .libs/hellomotif
 hellomotif.o  -L/opt/local/lib ../../../lib/Xm/.libs/libXm.dylib
 ../../../lib/Mrm/.libs/libMrm.dylib
 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_openmotif/openmotif/work/motif-2.3.4/lib/Xm/.libs/libXm.dylib
 -lXmu -lXext -lXt -lSM -lICE -lX11 -lXp -liconv -lXrender -lXft -ljpeg
 -lpng
 :info:build ../../../clients/uil/uil -o hellomotif.uid hellomotif.uil
 -I./../../../clients/uil -I../../../clients/uil
 :info:build
 :info:build Severe: internal error - submit defect report
 :info:build make[3]: *** [hellomotif.uid] Error 1
 :info:build make[3]: Leaving directory
 `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_openmotif/openmotif/work/motif-2.3.4/demos/programs/hellomotif'

 This may or may not have anything to do with the fact that I had to build
 xorg-libXt +flat_namespace +universal (previous variant was xorg-libXt
 +universal).

--
Ticket URL: <https://trac.macports.org/ticket/49395>
MacPorts <https://www.macports.org/>
Ports system for OS X
_______________________________________________
macports-tickets mailing list
[hidden email]
https://lists.macosforge.org/mailman/listinfo/macports-tickets
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #49395: openmotif: internal error: hellomotif fails to link

MacPorts
#49395: openmotif: internal error: hellomotif fails to link
------------------------+--------------------------------
  Reporter:  jries@…    |      Owner:  macports-tickets@…
      Type:  defect     |     Status:  new
  Priority:  Normal     |  Milestone:
 Component:  ports      |    Version:  2.3.4
Resolution:             |   Keywords:
      Port:  openmotif  |
------------------------+--------------------------------
Changes (by ryandesign@…):

 * port:   => openmotif


Old description:

> When doing a routine update (port upgrade outdated following port
> selfupdate), the compilation of openmotif fails as follows:
>
> Error: org.macports.build for port openmotif returned: command execution
> failed
> Please see the log file for port openmotif for details:
> /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_openmotif/openmotif/main.log
> Error: Unable to upgrade port: 1
> To report a bug, follow the instructions in the guide:
>     http://guide.macports.org/#project.tickets
>
> A look at the log indicates that build fails on the linking of hellomotif
> (starting at main.log:4538):
>
> :info:build /bin/sh ../../../libtool  --tag=CC   --mode=link
> /usr/bin/clang  -pipe -Os -arch x86_64 -Wall -g -fno-strict-aliasing
> -Wno-unused -Wno-comment -I/opt/local/include
> -I/opt/local/include/freetype2 -I/opt/local/include
> -I/opt/local/include/freetype2 -I/opt/local/include
> -I/opt/local/include/libpng16 -I/opt/local/include     -L/opt/local/lib
> -Wl,-headerpad_max_install_names -arch x86_64 -o hellomotif hellomotif.o
> ../../../lib/Xm/libXm.la ../../../lib/Mrm/libMrm.la -lXp -liconv
> -L/opt/local/lib -lXft -lXrender -L/opt/local/lib -lXft  -ljpeg -lpng
> :info:build libtool: link: /usr/bin/clang -pipe -Os -arch x86_64 -Wall -g
> -fno-strict-aliasing -Wno-unused -Wno-comment -I/opt/local/include
> -I/opt/local/include/freetype2 -I/opt/local/include
> -I/opt/local/include/freetype2 -I/opt/local/include
> -I/opt/local/include/libpng16 -I/opt/local/include
> -Wl,-headerpad_max_install_names -arch x86_64 -o .libs/hellomotif
> hellomotif.o  -L/opt/local/lib ../../../lib/Xm/.libs/libXm.dylib
> ../../../lib/Mrm/.libs/libMrm.dylib
> /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_openmotif/openmotif/work/motif-2.3.4/lib/Xm/.libs/libXm.dylib
> -lXmu -lXext -lXt -lSM -lICE -lX11 -lXp -liconv -lXrender -lXft -ljpeg
> -lpng
> :info:build ../../../clients/uil/uil -o hellomotif.uid hellomotif.uil
> -I./../../../clients/uil -I../../../clients/uil
> :info:build
> :info:build Severe: internal error - submit defect report
> :info:build make[3]: *** [hellomotif.uid] Error 1
> :info:build make[3]: Leaving directory
> `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_openmotif/openmotif/work/motif-2.3.4/demos/programs/hellomotif'
>
> This may or may not have anything to do with the fact that I had to build
> xorg-libXt +flat_namespace +universal (previous variant was xorg-libXt
> +universal).

New description:

 When doing a routine update (port upgrade outdated following port
 selfupdate), the compilation of openmotif fails as follows:

 {{{
 Error: org.macports.build for port openmotif returned: command execution
 failed
 Please see the log file for port openmotif for details:
 /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_openmotif/openmotif/main.log
 Error: Unable to upgrade port: 1
 To report a bug, follow the instructions in the guide:
     http://guide.macports.org/#project.tickets
 }}}

 A look at the log indicates that build fails on the linking of hellomotif
 (starting at main.log:4538):

 {{{
 :info:build /bin/sh ../../../libtool  --tag=CC   --mode=link
 /usr/bin/clang  -pipe -Os -arch x86_64 -Wall -g -fno-strict-aliasing -Wno-
 unused -Wno-comment -I/opt/local/include -I/opt/local/include/freetype2
 -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include
 -I/opt/local/include/libpng16 -I/opt/local/include     -L/opt/local/lib
 -Wl,-headerpad_max_install_names -arch x86_64 -o hellomotif hellomotif.o
 ../../../lib/Xm/libXm.la ../../../lib/Mrm/libMrm.la -lXp -liconv
 -L/opt/local/lib -lXft -lXrender -L/opt/local/lib -lXft  -ljpeg -lpng
 :info:build libtool: link: /usr/bin/clang -pipe -Os -arch x86_64 -Wall -g
 -fno-strict-aliasing -Wno-unused -Wno-comment -I/opt/local/include
 -I/opt/local/include/freetype2 -I/opt/local/include
 -I/opt/local/include/freetype2 -I/opt/local/include
 -I/opt/local/include/libpng16 -I/opt/local/include
 -Wl,-headerpad_max_install_names -arch x86_64 -o .libs/hellomotif
 hellomotif.o  -L/opt/local/lib ../../../lib/Xm/.libs/libXm.dylib
 ../../../lib/Mrm/.libs/libMrm.dylib
 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_openmotif/openmotif/work/motif-2.3.4/lib/Xm/.libs/libXm.dylib
 -lXmu -lXext -lXt -lSM -lICE -lX11 -lXp -liconv -lXrender -lXft -ljpeg
 -lpng
 :info:build ../../../clients/uil/uil -o hellomotif.uid hellomotif.uil
 -I./../../../clients/uil -I../../../clients/uil
 :info:build
 :info:build Severe: internal error - submit defect report
 :info:build make[3]: *** [hellomotif.uid] Error 1
 :info:build make[3]: Leaving directory
 `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_openmotif/openmotif/work/motif-2.3.4/demos/programs/hellomotif'
 }}}

 This may or may not have anything to do with the fact that I had to build
 xorg-libXt +flat_namespace +universal (previous variant was xorg-libXt
 +universal).

--

--
Ticket URL: <https://trac.macports.org/ticket/49395#comment:1>
MacPorts <https://www.macports.org/>
Ports system for OS X
_______________________________________________
macports-tickets mailing list
[hidden email]
https://lists.macosforge.org/mailman/listinfo/macports-tickets
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #49395: openmotif: internal error: hellomotif fails to link

MacPorts
In reply to this post by MacPorts
#49395: openmotif: internal error: hellomotif fails to link
------------------------+--------------------------------
  Reporter:  jries@…    |      Owner:  macports-tickets@…
      Type:  defect     |     Status:  new
  Priority:  Normal     |  Milestone:
 Component:  ports      |    Version:  2.3.4
Resolution:             |   Keywords:
      Port:  openmotif  |
------------------------+--------------------------------

Comment (by jries@…):

 Just to see what would happen, I tried to install openmotif +universal.  I
 got the following:

 --->  Computing dependencies for xorg-libXp
 --->  Fetching archive for xorg-libXp
 --->  Attempting to fetch xorg-
 libXp-1.0.3_0+universal.darwin_14.i386-x86_64.tbz2 from
 http://packages.macports.org/xorg-libXp
 --->  Attempting to fetch xorg-
 libXp-1.0.3_0+universal.darwin_14.i386-x86_64.tbz2 from
 http://mse.uk.packages.macports.org/sites/packages.macports.org/xorg-libXp
 --->  Attempting to fetch xorg-
 libXp-1.0.3_0+universal.darwin_14.i386-x86_64.tbz2 from
 http://lil.fr.packages.macports.org/xorg-libXp
 --->  Fetching distfiles for xorg-libXp
 --->  Attempting to fetch libXp-1.0.3.tar.bz2 from
 http://distfiles.macports.org/xorg-libXp
 --->  Verifying checksums for xorg-libXp
 --->  Extracting xorg-libXp
 --->  Configuring xorg-libXp
 --->  Building xorg-libXp
 --->  Staging xorg-libXp into destroot
 --->  Installing xorg-libXp @1.0.3_0+universal
 --->  Cleaning xorg-libXp
 --->  Computing dependencies for xorg-libXp
 --->  Deactivating xorg-libXp @1.0.3_0
 --->  Cleaning xorg-libXp
 --->  Activating xorg-libXp @1.0.3_0+universal
 --->  Cleaning xorg-libXp
 --->  Computing dependencies for openmotif
 --->  Fetching archive for openmotif
 --->  Attempting to fetch
 openmotif-2.3.4_3+universal.darwin_14.i386-x86_64.tbz2 from
 http://packages.macports.org/openmotif
 --->  Attempting to fetch
 openmotif-2.3.4_3+universal.darwin_14.i386-x86_64.tbz2 from
 http://mse.uk.packages.macports.org/sites/packages.macports.org/openmotif
 --->  Attempting to fetch
 openmotif-2.3.4_3+universal.darwin_14.i386-x86_64.tbz2 from
 http://lil.fr.packages.macports.org/openmotif
 --->  Fetching distfiles for openmotif
 --->  Verifying checksums for openmotif
 --->  Extracting openmotif
 --->  Applying patches to openmotif
 --->  Configuring openmotif
 --->  Building openmotif
 Error: org.macports.build for port openmotif returned: command execution
 failed
 To report a bug, follow the instructions in the guide:
     http://guide.macports.org/#project.tickets
 Error: Processing of port openmotif failed

 Apparently, it doesn't get far enough to write main.log, as the contents
 of that file now contain the output from the previously executed clean
 job.

--
Ticket URL: <https://trac.macports.org/ticket/49395#comment:2>
MacPorts <https://www.macports.org/>
Ports system for OS X
_______________________________________________
macports-tickets mailing list
[hidden email]
https://lists.macosforge.org/mailman/listinfo/macports-tickets
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #49395: openmotif: internal error: hellomotif fails to link

MacPorts
In reply to this post by MacPorts
#49395: openmotif: internal error: hellomotif fails to link
------------------------+--------------------------------
  Reporter:  jries@…    |      Owner:  macports-tickets@…
      Type:  defect     |     Status:  new
  Priority:  Normal     |  Milestone:
 Component:  ports      |    Version:  2.3.4
Resolution:             |   Keywords:
      Port:  openmotif  |
------------------------+--------------------------------
Changes (by ryandesign):

 * cc: root42 (added)


Comment:

 Has duplicate #53998.

--
Ticket URL: <https://trac.macports.org/ticket/49395#comment:4>
MacPorts <https://www.macports.org/>
Ports system for macOS