[MacPorts] #49307: Screen refreshing problem in kate

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[MacPorts] #49307: Screen refreshing problem in kate

MacPorts
#49307: Screen refreshing problem in kate
----------------------------+--------------------------------
 Reporter:  badindicator@…  |      Owner:  macports-tickets@…
     Type:  defect          |     Status:  new
 Priority:  Normal          |  Milestone:
Component:  ports           |    Version:  2.3.4
 Keywords:                  |       Port:  kate @4.14.3_0
----------------------------+--------------------------------
 On saving a file in kate (sometimes also on modifying a file), all symbols
 and menus go blank. Sending the app to the background fixes it until the
 next time I save a file (so cmd+tab hit twice will resolve it), so I guess
 this has to do with the drawing of the window. This is a fresh
 installation of macports, I also tried reinstalling it, cleaning it, etc.,
 the problem persists.

--
Ticket URL: <https://trac.macports.org/ticket/49307>
MacPorts <https://www.macports.org/>
Ports system for OS X
_______________________________________________
macports-tickets mailing list
[hidden email]
https://lists.macosforge.org/mailman/listinfo/macports-tickets
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #49307: kate @4.14.3_0: screen refreshing problem (was: Screen refreshing problem in kate)

MacPorts
#49307: kate @4.14.3_0: screen refreshing problem
-----------------------------+---------------------
  Reporter:  badindicator@…  |      Owner:  nicos@…
      Type:  defect          |     Status:  new
  Priority:  Normal          |  Milestone:
 Component:  ports           |    Version:  2.3.4
Resolution:                  |   Keywords:
      Port:  kate            |
-----------------------------+---------------------
Changes (by ryandesign@…):

 * owner:  macports-tickets@… => nicos@…
 * port:  kate @4.14.3_0 => kate


--
Ticket URL: <https://trac.macports.org/ticket/49307#comment:1>
MacPorts <https://www.macports.org/>
Ports system for OS X
_______________________________________________
macports-tickets mailing list
[hidden email]
https://lists.macosforge.org/mailman/listinfo/macports-tickets
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #49307: kate @4.14.3_0: screen refreshing problem

MacPorts
In reply to this post by MacPorts
#49307: kate @4.14.3_0: screen refreshing problem
-----------------------------+-------------------------
  Reporter:  badindicator@…  |      Owner:  NicosPavlov
      Type:  defect          |     Status:  new
  Priority:  Normal          |  Milestone:
 Component:  ports           |    Version:  2.3.4
Resolution:                  |   Keywords:
      Port:  kate            |
-----------------------------+-------------------------

Comment (by jnielsendotnet):

 I've been suffering with this issue as well.
 kate @4.14.3_4 (active)
 MacPorts 2.4.0
 ProductName:    Mac OS X
 ProductVersion: 10.11.6
 BuildVersion:   15G1217

--
Ticket URL: <https://trac.macports.org/ticket/49307#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #49307: kate @4.14.3_0: screen refreshing problem

MacPorts
In reply to this post by MacPorts
#49307: kate @4.14.3_0: screen refreshing problem
-----------------------------+-------------------------
  Reporter:  badindicator@…  |      Owner:  NicosPavlov
      Type:  defect          |     Status:  new
  Priority:  Normal          |  Milestone:
 Component:  ports           |    Version:  2.3.4
Resolution:                  |   Keywords:
      Port:  kate            |
-----------------------------+-------------------------

Comment (by NicosPavlov):

 Does this issue happen all the time, or only in certain cases? I tried to
 reproduce it, and this problem of refreshing menus never occurred for me.

--
Ticket URL: <https://trac.macports.org/ticket/49307#comment:5>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #49307: kate @4.14.3_0: screen refreshing problem

MacPorts
In reply to this post by MacPorts
#49307: kate @4.14.3_0: screen refreshing problem
-----------------------------+-------------------------
  Reporter:  badindicator@…  |      Owner:  NicosPavlov
      Type:  defect          |     Status:  new
  Priority:  Normal          |  Milestone:
 Component:  ports           |    Version:  2.3.4
Resolution:                  |   Keywords:
      Port:  kate            |
-----------------------------+-------------------------

Comment (by jnielsendotnet):

 It's all the time for me. Any time I drag a kwrite window to another
 display or save and then continue editing (one more keystroke) most or all
 of the edit window plus the status bar, scroll bars and left context bar
 turn the color of the status bar background. Moving the cursor around will
 cause parts of the window to be re-drawn but to re-draw the whole thing I
 have to either resize the window or switch (cmd-tab) to another
 application and switch back.

 If I set the window to fullscreen the problem doesn't occur.

 I'm running El Capitan 10.11.6 but also remember seeing the problem under
 Mavericks.

--
Ticket URL: <https://trac.macports.org/ticket/49307#comment:6>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: [MacPorts] #49307: kate @4.14.3_0: screen refreshing problem

MacPorts
In reply to this post by MacPorts
#49307: kate @4.14.3_0: screen refreshing problem
-----------------------------+-------------------------
  Reporter:  badindicator@…  |      Owner:  NicosPavlov
      Type:  defect          |     Status:  new
  Priority:  Normal          |  Milestone:
 Component:  ports           |    Version:  2.3.4
Resolution:                  |   Keywords:
      Port:  kate            |
-----------------------------+-------------------------

Comment (by jnielsendotnet):

 I recently updated to macOS Sierra (including re-installing all my
 MacPorts) and I'm no longer seeing this issue.

 $ port -qv installed kate
   kate @4.14.3_4 (active) platform='darwin 16' archs='x86_64'
 date='2017-07-05T10:37:40-0600'
 $ sw_vers
 ProductName:    Mac OS X
 ProductVersion: 10.12.5
 BuildVersion:   16F73

 I'm running the exact same version of kate as I used to be but some of the
 dependencies are slightly newer versions, including poppler-qt4-mac and
 qt4-mac.

 I'd be curious to know if anyone either a) is running Sierra and still
 having this issue or b) removes and reinstalls all their ports on
 Mavericks or El Capitan and sees the issue go away.

--
Ticket URL: <https://trac.macports.org/ticket/49307#comment:7>
MacPorts <https://www.macports.org/>
Ports system for macOS