Fwd: X11 SDK headers on Leopard?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Fwd: X11 SDK headers on Leopard?

William Davis


Begin forwarded message:

From: Simone Karin Lehmann <[hidden email]>
Date: December 7, 2007 4:29:29 PM EST
To: X11 List Mailing <[hidden email]>
Subject: Re: X11 SDK headers on Leopard?


Am 07.12.2007 um 20:27 schrieb Sergey Chemishkian:

I am trying to install MacPorts 1.5.0 on Leopard (upgraded from Tiger,
default Xcode 3.0 installation) from source. './configure' breaks on X11
tests with the following error message:

checking for XOpenDisplay in -lX11... yes
Please install the X11 SDK packages from the Xcode Developer Tools CD
configure: error: Broken X11 install. No X11 headers


I've had the same problem. There seems to be a bug with MacPorts on Leopard. Compiling MacPorts with

./configure LDFLAGS=-L/usr/X11/lib

solved the problem for me

Simone
--
in the arms of your angel, you may find some comfort here.




_______________________________________________
Do not post admin requests to the list. They will be ignored.
X11-users mailing list      ([hidden email])
Help/Unsubscribe/Update your Subscription: http://lists.apple.com/mailman/options/x11-users/frstan%40bellsouth.net

This email sent to [hidden email]



William Davis
frstanATbellsouthDOTnet
Mac OS X.5.1 Darwin 9.1.0
X11.app 2.1.0 - X.org X11R7.2
Mac Mini Intel Duo @ 1.86 GHz

Mundus vult decepi, ego non


_______________________________________________
macports-users mailing list
[hidden email]
http://lists.macosforge.org/mailman/listinfo/macports-users
Reply | Threaded
Open this post in threaded view
|

Re: X11 SDK headers on Leopard?

Ryan Schmidt-24
On Dec 7, 2007, at 16:43, William Davis wrote:

> Begin forwarded message:
>
>> From: Simone Karin Lehmann <[hidden email]>
>> Date: December 7, 2007 4:29:29 PM EST
>> To: X11 List Mailing <[hidden email]>
>> Subject: Re: X11 SDK headers on Leopard?
>>
>> Am 07.12.2007 um 20:27 schrieb Sergey Chemishkian:
>>
>>> I am trying to install MacPorts 1.5.0 on Leopard (upgraded from  
>>> Tiger,
>>> default Xcode 3.0 installation) from source. './configure' breaks  
>>> on X11
>>> tests with the following error message:
>>>
>>> checking for XOpenDisplay in -lX11... yes
>>> Please install the X11 SDK packages from the Xcode Developer  
>>> Tools CD
>>> configure: error: Broken X11 install. No X11 headers
>>
>> I've had the same problem. There seems to be a bug with MacPorts  
>> on Leopard. Compiling MacPorts with
>>
>> ./configure LDFLAGS=-L/usr/X11/lib
>>
>> solved the problem for me

Curious. We have people using MacPorts on Leopard right now. Just  
look at the dozens of bugs filed in the issue tracker. So how are all  
these people managing to use it?

Perhaps they're installing from the disk image instead of building  
from source, but that disk image was produced by someone using  
Leopard...

_______________________________________________
macports-users mailing list
[hidden email]
http://lists.macosforge.org/mailman/listinfo/macports-users