Cannot upgrade libpurple

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Cannot upgrade libpurple

Kurt Pfeifle via macports-users
Hi!

I found while trying to install another package, I cannot
upgrade libpurple, apparently because, "Tk 8.6 must be compiled
with tcl.h from Tcl 8.6 or better." Log file attached. Some
info:

bash-3.2# uname -v
Darwin Kernel Version 13.4.0: Mon Jan 11 18:17:34 PST 2016; root:xnu-2422.115.15~1/RELEASE_X86_64
bash-3.2# port version
Version: 2.4.1
bash-3.2# port list active and 'tcl'
Warning: The 'list' action only shows the currently available version of each port. To see installed versions, use the 'installed' action.
tcl                            @8.6.6          lang/tcl
bash-3.2# port list active and 'tk'
Warning: The 'list' action only shows the currently available version of each port. To see installed versions, use the 'installed' action.
tk                             @8.6.6          x11/tk

Do you know any workaround?

Thank you!

--
    ____  ____  ____  ____ (stephan paul) Arif Sahari Wibowo
   /___  /___/ /___/ /___      http://www.arifsaha.com/
  ____/ /     /   / ____/

main.log (138K) Download Attachment
output.txt (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot upgrade libpurple

Ryan Schmidt-24

On Apr 14, 2017, at 04:06, S P Arif Sahari Wibowo wrote:

> I found while trying to install another package, I cannot upgrade libpurple, apparently because, "Tk 8.6 must be compiled with tcl.h from Tcl 8.6 or better." Log file attached. Some info:
>
> bash-3.2# uname -v
> Darwin Kernel Version 13.4.0: Mon Jan 11 18:17:34 PST 2016; root:xnu-2422.115.15~1/RELEASE_X86_64
> bash-3.2# port version
> Version: 2.4.1
> bash-3.2# port list active and 'tcl'
> Warning: The 'list' action only shows the currently available version of each port. To see installed versions, use the 'installed' action.
> tcl                            @8.6.6          lang/tcl
> bash-3.2# port list active and 'tk'
> Warning: The 'list' action only shows the currently available version of each port. To see installed versions, use the 'installed' action.
> tk                             @8.6.6          x11/tk
>
> Do you know any workaround?

I agree, this problem occurs for me too, despite the fact that tcl and tk 8.6.6 are installed. I don't know why. You should file a bug report.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot upgrade libpurple

Kurt Pfeifle via macports-users
On 2017-04-14, 03:30, Ryan Schmidt wrote:
> I agree, this problem occurs for me too, despite the fact that
> tcl and tk 8.6.6 are installed. I don't know why. You should
> file a bug report.

Ticket submitted - https://trac.macports.org/ticket/53982

--
    ____  ____  ____  ____ (stephan paul) Arif Sahari Wibowo
   /___  /___/ /___/ /___      http://www.arifsaha.com/
  ____/ /     /   / ____/
Loading...