Back level boost libraries available?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Back level boost libraries available?

S. L. Garwood
I need boost 1.65 … is it available on MacPorts? All I see is 1.66

Reply | Threaded
Open this post in threaded view
|

Re: Back level boost libraries available?

Ryan Schmidt-24

On Mar 10, 2018, at 14:53, S. L. Garwood wrote:

> I need boost 1.65 … is it available on MacPorts? All I see is 1.66

No, MacPorts provides only the current version of a port.

Instructions for installing an older version of a port are here:

https://trac.macports.org/wiki/howto/InstallingOlderPort

However, if you downgrade boost to 1.65, that will probably break any ports you've installed that depend on boost. So I don't recommend you do that.

Why do you need 1.65?

Reply | Threaded
Open this post in threaded view
|

Re: Back level boost libraries available?

S. L. Garwood


> On Mar 10, 2018, at 4:53 PM, Ryan Schmidt <[hidden email]> wrote:
>
>
> On Mar 10, 2018, at 14:53, S. L. Garwood wrote:
>
>> I need boost 1.65 … is it available on MacPorts? All I see is 1.66
>
> No, MacPorts provides only the current version of a port.
>
> Instructions for installing an older version of a port are here:
>
> https://trac.macports.org/wiki/howto/InstallingOlderPort
>
> However, if you downgrade boost to 1.65, that will probably break any ports you've installed that depend on boost. So I don't recommend you do that.
>
> Why do you need 1.65?

error: use of class template 'boost::asio::strand' requires template arguments boost::asio::strand* _strand;
Common problem with 1.66 due to rework of asio::
1.65 worked fine