Anyone successfully install "meld"? Failed on gstreamer1-gst-plugins-bad

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Anyone successfully install "meld"? Failed on gstreamer1-gst-plugins-bad

James Kulp
I kept getting:

--->  Building gstreamer1-gst-plugins-bad
Error: Failed to build gstreamer1-gst-plugins-bad: command execution failed
Error: See
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_gstreamer1-gst-plugins-bad/gstreamer1-gst-plugins-bad/main.log
for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port meld failed

And the log had:

> :info:build libtool: compile: /usr/bin/clang -arch x86_64
> -DHAVE_CONFIG_H -I. -I../../.. -I/opt/local/include -L/opt/local/lib
> -I../../../gst-libs -I../../../gst-libs -DGST_USE_UNSTABLE_API
> -D_REENTRANT -I/opt/local/include/gstreamer-1.0
> -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include
> -DGST_USE_UNSTABLE_API -DG_THREADS_MANDATORY -DG_DISABLE_CAST_CHECKS
> -Wall -Wdeclaration-after-statement -Wvla -Wpointer-arith
> -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls
> -Wwrite-strings -Wformat-security -Wold-style-definition -Winit-self
> -Wmissing-include-dirs -Waddress -Wno-multichar -Wnested-externs -g
> -pipe -Os -std=c99 -funroll-loops -fstrict-aliasing -arch x86_64 -MT
> libgstmpegts_1.0_la-gst-dvb-descriptor.lo -MD -MP -MF
> .deps/libgstmpegts_1.0_la-gst-dvb-descriptor.Tpo -c
> gst-dvb-descriptor.c  -fno-common -DPIC -o
> .libs/libgstmpegts_1.0_la-gst-dvb-descriptor.o
> :info:build clang: warning: argument unused during compilation:
> '-L/opt/local/lib' [-Wunused-command-line-argument]
> :info:build /usr/include/signal.h:79: syntax error, unexpected
> identifier, expecting ')' in 'void (* _Nullable bsd_signal(int, void
> (* _Nullable)(int)))(int);' at 'bsd_signal'
> :info:build /usr/include/signal.h:79: syntax error, unexpected ')',
> expecting ',' or ';' in 'void (* _Nullable bsd_signal(int, void (*
> _Nullable)(int)))(int);' at ')'
> :info:build /usr/include/signal.h:99: syntax error, unexpected
> identifier, expecting ')' in 'void (* _Nullable sigset(int, void (*
> _Nullable)(int)))(int);' at 'sigset'
> :info:build /usr/include/signal.h:99: syntax error, unexpected ')',
> expecting ',' or ';' in 'void (* _Nullable sigset(int, void (*
> _Nullable)(int)))(int);' at ')'
> :info:build /usr/include/pthread/qos.h:113: syntax error, unexpected
> RESTRICT, expecting ')' or ',' in ' qos_class_t * _Nullable restrict
> __qos_class,' at 'restrict'
> :info:build /usr/include/pthread/qos.h:114: syntax error, unexpected
> INT, expecting identifier or '(' or '*' in '  int * _Nullable restrict
> __relative_priority);' at 'int'
> :info:build /usr/include/pthread/qos.h:114: syntax error, unexpected
> ')', expecting ',' or ';' in '  int * _Nullable restrict
> __relative_priority);' at ')'
> :info:build /usr/include/pthread/qos.h:185: syntax error, unexpected
> RESTRICT, expecting ')' or ',' in ' qos_class_t * _Nullable restrict
> __qos_class,' at 'restrict'
> :info:build /usr/include/pthread/qos.h:186: syntax error, unexpected
> INT, expecting identifier or '(' or '*' in '  int * _Nullable restrict
> __relative_priority);' at 'int'
> :info:build /usr/include/pthread/qos.h:186: syntax error, unexpected
> ')', expecting ',' or ';' in '  int * _Nullable restrict
> __relative_priority);' at ')'
> :info:build /usr/include/pthread/pthread.h:243: syntax error,
> unexpected '*', expecting ')' or ',' in '  void * _Nullable * _Nonnull
> restrict, size_t * restrict);' at '*'
> :info:build /usr/include/pthread/pthread.h:243: syntax error,
> unexpected ')', expecting identifier or '(' in '  void * _Nullable *
> _Nonnull restrict, size_t * restrict);' at ')'
> :info:build /usr/include/pthread/pthread.h:247: syntax error,
> unexpected '*', expecting ')' or ',' in '  void * _Nullable * _Nonnull
> restrict);' at '*'
> :info:build /usr/include/pthread/pthread.h:295: syntax error,
> unexpected RESTRICT, expecting ')' or ',' in '  const
> pthread_condattr_t * _Nullable restrict)' at 'restrict'
> :info:build /usr/include/pthread/pthread.h:304: syntax error,
> unexpected RESTRICT, expecting ')' or ',' in '  const struct timespec
> * _Nullable restrict)' at 'restrict'
> :info:build /usr/include/pthread/pthread.h:326: syntax error,
> unexpected '*', expecting ')' or ',' in 'int pthread_create(pthread_t
> _Nullable * _Nonnull restrict,' at '*'
> :info:build /usr/include/pthread/pthread.h:327: syntax error,
> unexpected ',', expecting identifier or '(' or '*' or ';' in '  const
> pthread_attr_t * _Nullable restrict,' at ','
> :info:build /usr/include/pthread/pthread.h:328: syntax error,
> unexpected '*' in '  void * _Nullable (* _Nonnull)(void * _Nullable),'
> at '*'
> :info:build /usr/include/pthread/pthread.h:328: syntax error,
> unexpected ')', expecting ',' or ';' in '  void * _Nullable (*
> _Nonnull)(void * _Nullable),' at ')'
> :info:build /usr/include/pthread/pthread.h:329: syntax error,
> unexpected ')', expecting identifier or '(' or '*' or ';' in '  void *
> _Nullable restrict);' at ')'
> :info:build /usr/include/pthread/pthread.h:349: syntax error,
> unexpected RESTRICT, expecting ')' or ',' in 'int
> pthread_getschedparam(pthread_t , int * _Nullable restrict,' at 'restrict'
> :info:build /usr/include/pthread/pthread.h:350: syntax error,
> unexpected ')', expecting identifier or '(' or '*' or ';' in '  struct
> sched_param * _Nullable restrict);' at ')'
> :info:build /usr/include/pthread/pthread.h:353: syntax error,
> unexpected identifier, expecting ',' or ';' in 'void* _Nullable
> pthread_getspecific(pthread_key_t);' at 'pthread_getspecific'
> :info:build /usr/include/pthread/pthread.h:356: syntax error,
> unexpected '*', expecting ')' or ',' in 'int pthread_join(pthread_t ,
> void * _Nullable * _Nullable)' at '*'
> :info:build /usr/include/pthread/pthread.h:374: syntax error,
> unexpected RESTRICT, expecting ')' or ',' in '  const
> pthread_mutexattr_t * _Nullable restrict);' at 'restrict'
> :info:build /usr/include/pthread/pthread.h:432: syntax error,
> unexpected RESTRICT, expecting ')' or ',' in '  const
> pthread_rwlockattr_t * _Nullable restrict)' at 'restrict'
> :info:build /usr/include/pthread/pthread.h:529: syntax error,
> unexpected '*', expecting ')' or ',' in '  pthread_t _Nullable *
> _Nonnull, const pthread_attr_t * _Nullable,' at '*'
> :info:build /usr/include/pthread/pthread.h:530: syntax error,
> unexpected VOID, expecting identifier or '(' or '*' in '  void *
> _Nullable (* _Nonnull)(void * _Nullable), void * _Nullable);' at 'void'
> :info:build /usr/include/pthread/pthread.h:530: syntax error,
> unexpected '*' in '  void * _Nullable (* _Nonnull)(void * _Nullable),
> void * _Nullable);' at '*'
> :info:build /usr/include/pthread/pthread.h:530: syntax error,
> unexpected ')', expecting ',' or ';' in '  void * _Nullable (*
> _Nonnull)(void * _Nullable), void * _Nullable);' at ')'
> :info:build /usr/include/pthread/pthread.h:530: syntax error,
> unexpected ')', expecting ',' or ';' in '  void * _Nullable (*
> _Nonnull)(void * _Nullable), void * _Nullable);' at ')'
> :info:build /usr/include/pthread/pthread.h:540: syntax error,
> unexpected identifier in '_Nullable pthread_t
> pthread_from_mach_thread_np(mach_port_t);' at '_Nullable'
and then proceeds to ignore this error, do a bunch more building, and
then failing again later with other similar errors and:

> :info:build ./gstopenjpeg.h:42:12: fatal error:
> 'openjpeg-2.1/openjpeg.h' file not found
and finally

> :error:build Failed to build gstreamer1-gst-plugins-bad: command
> execution failed

db
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Anyone successfully install "meld"? Failed on gstreamer1-gst-plugins-bad

db
It's good to know that meld is on macports. In trac, there's a patch at https://trac.macports.org/ticket/51512 for 3.16.0, which you might want to give a try.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Anyone successfully install "meld"? Failed on gstreamer1-gst-plugins-bad

Ryan Schmidt-24
In reply to this post by James Kulp
On Aug 12, 2017, at 08:20, James Kulp wrote:

> :info:build /usr/include/signal.h:79: syntax error, unexpected identifier, expecting ')' in 'void (* _Nullable bsd_signal(int, void (* _Nullable)(int)))(int);' at 'bsd_signal'

An error in a file in /usr/include makes me suspicious that you may not have the correct version of the command line tools. Please try updating or reinstalling the version of the command line tools that is appropriate for your version of macOS and matches the version of Xcode you have installed.


On Aug 12, 2017, at 14:23, db wrote:

> In trac, there's a patch at https://trac.macports.org/ticket/51512 for 3.16.0, which you might want to give a try.

The availability of an update for meld will have no effect on James' inability to build one of meld's dependencies.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Anyone successfully install "meld"? Failed on gstreamer1-gst-plugins-bad

James Kulp
Thank you for that suggestion.  I updated to command line tools 8.3.2 (I
have xcode 8.3.3) but the /usr/include* problems are there, as well as the:
> :info:build In file included from gstopenjpegdec.c:27:
> :info:build In file included from ./gstopenjpegdec.h:29:
> :info:build ./gstopenjpeg.h:42:12: fatal error:
> 'openjpeg-2.1/openjpeg.h' file not found
> :info:build #  include <openjpeg-2.1/openjpeg.h>
> :info:build            ^

On 8/15/17 6:52 AM, Ryan Schmidt wrote:

> On Aug 12, 2017, at 08:20, James Kulp wrote:
>
>> :info:build /usr/include/signal.h:79: syntax error, unexpected identifier, expecting ')' in 'void (* _Nullable bsd_signal(int, void (* _Nullable)(int)))(int);' at 'bsd_signal'
> An error in a file in /usr/include makes me suspicious that you may not have the correct version of the command line tools. Please try updating or reinstalling the version of the command line tools that is appropriate for your version of macOS and matches the version of Xcode you have installed.
>
>
> On Aug 12, 2017, at 14:23, db wrote:
>
>> In trac, there's a patch at https://trac.macports.org/ticket/51512 for 3.16.0, which you might want to give a try.
> The availability of an update for meld will have no effect on James' inability to build one of meld's dependencies.
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Anyone successfully install "meld"? Failed on gstreamer1-gst-plugins-bad

Ken Cunningham
openjpeg has bumped up to 2.2, so many ports are failing to build.

the include needs to get changed to

#include <openjpeg-2.2/openjpeg.h>

Ken


On 2017-08-15, at 11:19 AM, James Kulp wrote:

> Thank you for that suggestion.  I updated to command line tools 8.3.2 (I have xcode 8.3.3) but the /usr/include* problems are there, as well as the:
>> :info:build In file included from gstopenjpegdec.c:27:
>> :info:build In file included from ./gstopenjpegdec.h:29:
>> :info:build ./gstopenjpeg.h:42:12: fatal error: 'openjpeg-2.1/openjpeg.h' file not found
>> :info:build #  include <openjpeg-2.1/openjpeg.h>
>> :info:build            ^
>
> On 8/15/17 6:52 AM, Ryan Schmidt wrote:
>> On Aug 12, 2017, at 08:20, James Kulp wrote:
>>
>>> :info:build /usr/include/signal.h:79: syntax error, unexpected identifier, expecting ')' in 'void (* _Nullable bsd_signal(int, void (* _Nullable)(int)))(int);' at 'bsd_signal'
>> An error in a file in /usr/include makes me suspicious that you may not have the correct version of the command line tools. Please try updating or reinstalling the version of the command line tools that is appropriate for your version of macOS and matches the version of Xcode you have installed.
>>
>>
>> On Aug 12, 2017, at 14:23, db wrote:
>>
>>> In trac, there's a patch at https://trac.macports.org/ticket/51512 for 3.16.0, which you might want to give a try.
>> The availability of an update for meld will have no effect on James' inability to build one of meld's dependencies.
>>
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Anyone successfully install "meld"? Failed on gstreamer1-gst-plugins-bad

Clemens Lang-2


----- On 15 Aug, 2017, at 21:11, Ken Cunningham [hidden email] wrote:

> openjpeg has bumped up to 2.2, so many ports are failing to build.
>
> the include needs to get changed to
>
> #include <openjpeg-2.2/openjpeg.h>

This is fixed for gstreamer1-gst-plugins-bad in:
https://github.com/macports/macports-ports/commit/20dd35b3147ff00c1fa0f1b7f17625301baa4883

Upstream for the problem is https://bugzilla.gnome.org/show_bug.cgi?id=786250.

--
Clemens Lang
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Anyone successfully install "meld"? Failed on gstreamer1-gst-plugins-bad

James Kulp
Thanks all for the help.  After a selfupdate,

gstreamer1-gst-plugins-bad

installed ok, and the rest of the dependencies from "meld" also were
fine, and "meld" is good.


On 8/16/17 6:28 AM, Clemens Lang wrote:

>
> ----- On 15 Aug, 2017, at 21:11, Ken Cunningham [hidden email] wrote:
>
>> openjpeg has bumped up to 2.2, so many ports are failing to build.
>>
>> the include needs to get changed to
>>
>> #include <openjpeg-2.2/openjpeg.h>
> This is fixed for gstreamer1-gst-plugins-bad in:
> https://github.com/macports/macports-ports/commit/20dd35b3147ff00c1fa0f1b7f17625301baa4883
>
> Upstream for the problem is https://bugzilla.gnome.org/show_bug.cgi?id=786250.
>

db
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Anyone successfully install "meld"? Failed on gstreamer1-gst-plugins-bad

db
On 16 Aug 2017, at 14:12, James Kulp <[hidden email]> wrote:
> Thanks all for the help.  After a selfupdate, gstreamer1-gst-plugins-bad installed ok, and the rest of the dependencies from "meld" also were fine, and "meld" is good.

Can anyone take a look at #51512 (3.16.0)? Alternatively, this version is also available at https://github.com/yousseb/meld/releases.
Loading...