#60783: lua @5.3.5 invalid dylib version

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

#60783: lua @5.3.5 invalid dylib version

macports-4
#60783: lua @5.3.5 invalid dylib version
----------------------+--------------------
 Reporter:  ierofant  |      Owner:  (none)
     Type:  defect    |     Status:  new
 Priority:  Normal    |  Milestone:
Component:  ports     |    Version:  2.6.2
 Keywords:            |       Port:
----------------------+--------------------
 liblua.dylib not loading
 {{{
 $ sudo port install lua
 $ lua
 dyld: Library not loaded: /opt/local/lib/liblua.dylib
   Referenced from: /opt/local/bin/lua
   Reason: Incompatible library version: lua requires version 5.3.0 or
 later, but liblua.dylib provides version 0.0.0
 Abort trap: 6
 }}}

 macOS Catalina Version 10.15.5

 Xcode 11.3 Build version 11C29

--
Ticket URL: <https://trac.macports.org/ticket/60783>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: #60783: lua @5.3.5 invalid dylib version

macports-4
#60783: lua @5.3.5 invalid dylib version
-----------------------+--------------------
  Reporter:  ierofant  |      Owner:  (none)
      Type:  defect    |     Status:  new
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.6.2
Resolution:            |   Keywords:
      Port:            |
-----------------------+--------------------

Comment (by mf2k):

 In the future, please fill in the Port field and add the port
 maintainer(s) to Cc ({{{port info --maintainers lua}}}), if any.

--
Ticket URL: <https://trac.macports.org/ticket/60783#comment:1>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: #60783: lua @5.3.5 invalid dylib version

macports-4
In reply to this post by macports-4
#60783: lua @5.3.5 invalid dylib version
-----------------------+--------------------
  Reporter:  ierofant  |      Owner:  (none)
      Type:  defect    |     Status:  new
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.6.2
Resolution:            |   Keywords:
      Port:  lua       |
-----------------------+--------------------
Changes (by mf2k):

 * port:   => lua


--
Ticket URL: <https://trac.macports.org/ticket/60783#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: #60783: lua @5.3.5 invalid dylib version

macports-4
In reply to this post by macports-4
#60783: lua @5.3.5 invalid dylib version
-----------------------+--------------------
  Reporter:  ierofant  |      Owner:  (none)
      Type:  defect    |     Status:  new
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.6.2
Resolution:            |   Keywords:
      Port:  lua       |
-----------------------+--------------------

Comment (by ryandesign):

 I can't reproduce that. It works fine for me:

 {{{
 $ otool -L /opt/local/lib/liblua.dylib /opt/local/bin/lua
 /opt/local/lib/liblua.dylib:
         /opt/local/lib/liblua.dylib (compatibility version 5.3.0, current
 version 5.3.5)
         /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current
 version 1252.50.4)
 /opt/local/bin/lua:
         /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current
 version 1252.50.4)
         /opt/local/lib/libreadline.8.dylib (compatibility version 8.0.0,
 current version 8.0.0)
         /opt/local/lib/liblua.dylib (compatibility version 5.3.0, current
 version 5.3.5)
 $ lua
 Lua 5.3.5  Copyright (C) 1994-2018 Lua.org, PUC-Rio
 >
 }}}

 I'm on High Sierra, not Catalina, but I also examined our precompiled
 binary of lua for Catalina and it looks like it's fine too.

 Please try reinstalling lua by running:

 {{{
 $ sudo port clean lua
 $ sudo port -n upgrade --force lua
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/60783#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: #60783: lua @5.3.5 invalid dylib version

macports-4
In reply to this post by macports-4
#60783: lua @5.3.5 invalid dylib version
-----------------------+--------------------
  Reporter:  ierofant  |      Owner:  (none)
      Type:  defect    |     Status:  new
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.6.2
Resolution:            |   Keywords:
      Port:  lua       |
-----------------------+--------------------

Comment (by ierofant):

 I tried to reinstall and upgrade Lua many times, unfortunately it does not
 help for me

--
Ticket URL: <https://trac.macports.org/ticket/60783#comment:4>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: #60783: lua @5.3.5 invalid dylib version

macports-4
In reply to this post by macports-4
#60783: lua @5.3.5 invalid dylib version
-----------------------+--------------------
  Reporter:  ierofant  |      Owner:  (none)
      Type:  defect    |     Status:  new
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.6.2
Resolution:            |   Keywords:
      Port:  lua       |
-----------------------+--------------------

Comment (by kencu):

 Please give us the output of:
 {{{
 otool -L /opt/local/lib/liblua.dylib /opt/local/bin/lua
 }}}

--
Ticket URL: <https://trac.macports.org/ticket/60783#comment:5>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: #60783: lua @5.3.5 invalid dylib version

macports-4
In reply to this post by macports-4
#60783: lua @5.3.5 invalid dylib version
-----------------------+--------------------
  Reporter:  ierofant  |      Owner:  (none)
      Type:  defect    |     Status:  new
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.6.2
Resolution:            |   Keywords:
      Port:  lua       |
-----------------------+--------------------

Comment (by ierofant):

 I found a problem with my system. Is was another liblua. Thank you very
 much for your help!

--
Ticket URL: <https://trac.macports.org/ticket/60783#comment:6>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: #60783: lua @5.3.5 invalid dylib version

macports-4
In reply to this post by macports-4
#60783: lua @5.3.5 invalid dylib version
-----------------------+----------------------
  Reporter:  ierofant  |      Owner:  ierofant
      Type:  defect    |     Status:  assigned
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.6.2
Resolution:            |   Keywords:
      Port:  lua       |
-----------------------+----------------------
Changes (by ierofant):

 * status:  new => assigned
 * owner:  (none) => ierofant


--
Ticket URL: <https://trac.macports.org/ticket/60783#comment:7>
MacPorts <https://www.macports.org/>
Ports system for macOS
Reply | Threaded
Open this post in threaded view
|

Re: #60783: lua @5.3.5 invalid dylib version

macports-4
In reply to this post by macports-4
#60783: lua @5.3.5 invalid dylib version
-----------------------+----------------------
  Reporter:  ierofant  |      Owner:  ierofant
      Type:  defect    |     Status:  closed
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.6.2
Resolution:  invalid   |   Keywords:
      Port:  lua       |
-----------------------+----------------------
Changes (by kencu):

 * status:  assigned => closed
 * resolution:   => invalid


Comment:

 glad you got it sorted out!

--
Ticket URL: <https://trac.macports.org/ticket/60783#comment:8>
MacPorts <https://www.macports.org/>
Ports system for macOS